Closed Bug 602985 Opened 10 years ago Closed 10 years ago

JS error: _dragger is null

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: stechz, Assigned: stechz)

References

Details

Attachments

(1 file)

http://mxr.mozilla.org/mobile-browser/source/chrome/content/input.js#326

_doDragStop assumes that no kinetic panning is occurring when it is called, and _kineticStop assumes that no dragging is occurring when it is called. Both _dragger = null statements need checks.
Duplicate of this bug: 602836
Regression from bug 592330.
Blocks: 592330
tracking-fennec: --- → ?
OS: Mac OS X → All
Hardware: x86 → All
Comment on attachment 481934 [details] [diff] [review]
JS error: _dragger is null

It turns out that the kinetic pan case already checks to see if we are dragging.

Matt, can you still reproduce the problem with this?
Attachment #481934 - Flags: review?(mbrubeck)
Comment on attachment 481934 [details] [diff] [review]
JS error: _dragger is null

I can no longer reproduce the bug with this patch, and it looks like it should fix the problem based on my debugging.
Attachment #481934 - Flags: review?(mbrubeck) → review+
stechz pushed this: http://hg.mozilla.org/mobile-browser/rev/a67f6b268942
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Sorry I missed this. Thanks Matt.
VERIFIED FIXED on:

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a1) Gecko/20110609 Firefox/7.0a1 Fennec/7.0a1 

Mozilla /5.0 (Android;Linux armv7l;rv:6.0a2) Gecko/20110608 Firefox/6.0a2 Fennec/6.0a2

Device: HTC Desire Z (Android 2.2)
Status: RESOLVED → VERIFIED
bugspam
Assignee: nobody → ben
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.