Downloading files with DownThemAll! causing Firefox to crash [@ XPCWrappedNative::Morph(XPCCallContext&, JSObject*, XPCNativeInterface*, nsWrapperCache*, XPCWrappedNative**) ] [@ IteratorNext ]

VERIFIED DUPLICATE of bug 602218

Status

()

--
critical
VERIFIED DUPLICATE of bug 602218
8 years ago
2 years ago

People

(Reporter: Virtual, Unassigned)

Tracking

({nightly-community})

Trunk
x86
Windows XP
nightly-community
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101008 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101008 Firefox/4.0b8pre

Crash reports from last days (some may be irrelevant) :
http://crash-stats.mozilla.com/report/index/bp-a43d96b7-9151-49ca-95e5-01ca32101008
http://crash-stats.mozilla.com/report/index/bp-b5136c06-5b82-4ad5-aa9c-fcbd02101008
http://crash-stats.mozilla.com/report/index/bp-8c84f521-5d78-4a7b-9385-3a0e32101008
http://crash-stats.mozilla.com/report/index/bp-68d0c996-4176-457f-b54e-70b4d2101007
http://crash-stats.mozilla.com/report/index/bp-7533642d-e1da-4a67-b4b8-893fb2101007
http://crash-stats.mozilla.com/report/index/bp-5156d432-3bea-4615-b984-037be2101007
http://crash-stats.mozilla.com/report/index/bp-0657be78-e369-48ac-8859-5738c2101007
http://crash-stats.mozilla.com/report/index/bp-2ee738be-e242-4698-b2ad-785392101007
http://crash-stats.mozilla.com/report/index/bp-637b5c33-928a-4368-91b9-1c9182101007
http://crash-stats.mozilla.com/report/index/bp-5ddb8c07-81aa-43af-8374-6f9502101007
http://crash-stats.mozilla.com/report/index/bp-2d748854-89bb-482f-b483-be4732101007
http://crash-stats.mozilla.com/report/index/bp-d0463bab-7347-4ad5-ab74-b105c2101007
http://crash-stats.mozilla.com/report/index/bp-eecfe212-7c76-45b2-a031-e61e42101005
http://crash-stats.mozilla.com/report/index/bp-12e19022-6fd6-4923-9feb-671d62101005
http://crash-stats.mozilla.com/report/index/bp-b540fe86-a34f-4414-86bf-7aef02101004
http://crash-stats.mozilla.com/report/index/bp-bb9bbb7e-1890-4085-988d-95e0c2101004
http://crash-stats.mozilla.com/report/index/bp-3a6df9c0-f60b-436a-86e4-1dce42101004
http://crash-stats.mozilla.com/report/index/bp-52b38055-3c21-48f0-8772-1afec2101004
http://crash-stats.mozilla.com/report/index/bp-a70f581c-276d-48d6-a991-33ebb2101004
http://crash-stats.mozilla.com/report/index/bp-98829819-f3e1-4d42-8ea0-e3e852101004
http://crash-stats.mozilla.com/report/index/bp-7792cf88-fc67-4697-bb93-7b0532101002
http://crash-stats.mozilla.com/report/index/bp-0c27cc23-a951-492b-b02b-f78da2100930
http://crash-stats.mozilla.com/report/index/bp-f64cfd51-ce02-4556-95d8-14c1f2100930
http://crash-stats.mozilla.com/report/index/bp-95b8c2a9-3100-4eba-92cf-9fa022100928
http://crash-stats.mozilla.com/report/index/bp-ada8dd69-046a-4f9a-b576-324ec2100925
http://crash-stats.mozilla.com/report/index/bp-c49eef25-5959-4575-9d88-521e12100924
http://crash-stats.mozilla.com/report/index/bp-785f2c4e-6499-45ec-82fd-3ed9f2100918
http://crash-stats.mozilla.com/report/index/bp-e09efc78-e508-4595-916a-8bbd92100914
http://crash-stats.mozilla.com/report/index/bp-7e612944-dd7c-44fd-ab5b-992402100913
http://crash-stats.mozilla.com/report/index/bp-0ee5821d-566f-4c01-b920-c4c672100913
http://crash-stats.mozilla.com/report/index/bp-cbe55974-6740-4534-b07e-e9f002100913

Reproducible: Sometimes

Steps to Reproduce:
1. Install latest Firefox nightly from https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/
2. Install latest DownThemAll! nightly from http://code.downthemall.net/nightly/trunk/
3. Go to some site with about 100 images and start downloading them (e.g. http://boards.4chan.org/wg/)
Actual Results:  
Crash will happen

Expected Results:  
No crash
blocking2.0: --- → ?
Version: unspecified → Trunk
Assuming your crash is [@ mozjs.dll@0x28ab ], bp-7533642d-e1da-4a67-b4b8-893fb2101007, because the comment here says you were downloading using DTA.
blocking2.0: ? → ---
Keywords: crash
Summary: Downloading files with DownThemAll! causing Firefox to crash → Downloading files with DownThemAll! causing Firefox to crash bp-7533642d-e1da-4a67-b4b8-893fb2101007
>1. Install latest Firefox nightly from
>https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/

That directory is a tinderbox build and those builds don't upload the symbols to the crash server.
2-3 crash IDs from a nightly would help (and we don't need 20 crash IDs)
(In reply to comment #1)
No, all crashes from 08.10.2010 to 08.10.2010 is "caused" by downloading files with DTA! (others probably too, but didn't know for sure)

Sometimes mozjs.dll is crashing
http://crash-stats.mozilla.com/report/index/bp-a43d96b7-9151-49ca-95e5-01ca32101008

sometimes xul.dll
http://crash-stats.mozilla.com/report/index/bp-b5136c06-5b82-4ad5-aa9c-fcbd02101008

sometimes nothing...
http://crash-stats.mozilla.com/report/index/bp-68d0c996-4176-457f-b54e-70b4d2101007

(In reply to comment #2)
OK, so where I find this special builds with symbols, so I can update crashlog with it to server
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Summary: Downloading files with DownThemAll! causing Firefox to crash bp-7533642d-e1da-4a67-b4b8-893fb2101007 → Downloading files with DownThemAll! causing Firefox to crash [@ XPCWrappedNative::Morph(XPCCallContext&, JSObject*, XPCNativeInterface*, nsWrapperCache*, XPCWrappedNative**) ] [@ IteratorNext ]

Comment 6

8 years ago
Signature	XPCWrappedNative::Morph(XPCCallContext&, JSObject*, XPCNativeInterface*, nsWrapperCache*, XPCWrappedNative**)
UUID	8879ab04-935f-4535-ad57-441af2101009
Time 	2010-10-09 04:28:27.193732
Uptime	136
Last Crash	43869 seconds (12.2 hours) before submission
Install Age	171 seconds since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101008041525
Branch	2.0
OS	Windows NT
OS Version	5.1.2600 Dodatek Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 11
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x10
User Comments	downloading files with DownThemAll!
App Notes 	AdapterVendorID: 10de, AdapterDeviceID: 0402
Processor Notes 	
EMCheckCompatibility	False
Related Bugs

---

        * 602218 Bug NEW crash mainly at start-up and on Windows 7 [@ XPCWrappedNative::Morph(XPCCallContext&, JSObject*, XPCNativeInterface*, nsWrapperCache*, XPCWrappedNative**) ]

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	XPCWrappedNative::Morph 	js/src/xpconnect/src/xpcwrappednative.cpp:753
1 	xul.dll 	MorphSlimWrapper 	js/src/xpconnect/src/xpcwrappednative.cpp:3847
2 	xul.dll 	XPC_WN_NoHelper_Resolve 	
3 	mozjs.dll 	CallResolveOp 	js/src/jsobj.cpp:4590
4 	mozjs.dll 	js_LookupPropertyWithFlags 	js/src/jsobj.cpp:4631
5 	mozjs.dll 	js_GetPropertyHelper 	js/src/jsobj.cpp:5068
6 	mozjs.dll 	js_GetMethod 	js/src/jsobj.cpp:5087
7 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4113
8 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
9 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:746
10 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:776
11 	mozjs.dll 	js::ExternalGetOrSet 	js/src/jsinterp.cpp:796
12 	mozjs.dll 	js::Shape::set 	js/src/jsscopeinlines.h:240
13 	mozjs.dll 	js_NativeSet 	js/src/jsobj.cpp:4933
14 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4234
15 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
16 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:746
17 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:776
18 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:4836
19 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1694
20 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:571
21 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
22 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
23 	xul.dll 	nsHttpChannel::CallOnStartRequest 	netwerk/protocol/http/nsHttpChannel.cpp:770
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 602218
You need to log in before you can comment on or make changes to this bug.