dataTransfer.types contains a 'Files' item but no File in dataTransfer.files

RESOLVED DUPLICATE of bug 1124775

Status

()

Core
Drag and Drop
RESOLVED DUPLICATE of bug 1124775
8 years ago
2 years ago

People

(Reporter: Hsu Ping Feng, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/534.7 (KHTML, like Gecko) Chrome/7.0.517.36 Safari/534.7
Build Identifier: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

While I drag an image from other firefox window/tabs, the page receive the ondrop event will get a 'Files' item in Event.dataTransfer.types but there's no 'File' object in Event.dataTransfer.files. This don't meet the description in html5 drag&drop spec about Event.dataTransfer.files.

Reproducible: Always

Steps to Reproduce:
1. write a html file that receives ondrop event and use console.log to probe the Event.dataTransfer
2. open another html that contained images in different window/tabs 
3. drag the image and drop it in the page in step 1
4. check the firebug console for information
Actual Results:  
Event.dataTransfer.types contains a 'Files' item, but there's no 'File' object in Event.dataTransfer.files FileList object.

Expected Results:  
If there's nothing in the Event.dataTransfer.files FileList, then there should not be 'Files' in any item of Event.dataTransfer.types.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1124775
You need to log in before you can comment on or make changes to this bug.