startup Crash in XPCWrappedNative::GetNewOrUsed mainly on Windows XP

RESOLVED DUPLICATE of bug 749655

Status

()

--
critical
RESOLVED DUPLICATE of bug 749655
8 years ago
2 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: startupcrash, crash signature)

(Reporter)

Description

8 years ago
It is a new crash signature that exists in trunk builds.
It is #152 top crasher in 4.0b6 for the last week.

Signature	XPCWrappedNative::GetNewOrUsed(XPCCallContext&, xpcObjectHelper&, XPCWrappedNativeScope*, XPCNativeInterface*, int, XPCWrappedNative**)
UUID	9302d71f-c13f-46d6-b317-691f82101009
Time 	2010-10-09 03:30:25.68055
Uptime	3326
Install Age	3326 seconds (55.4 minutes) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101008041525
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	AuthenticAMD family 16 model 4 stepping 2
Crash Reason	EXCEPTION_STACK_OVERFLOW
Crash Address	0x60877fb2
App Notes 	AdapterVendorID: 1002, AdapterDeviceID: 9501
Processor Notes 	This dump is too long and has triggered the automatic truncation routine

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	XPCWrappedNative::GetNewOrUsed 	js/src/xpconnect/src/xpcwrappednative.cpp:329
1 	xul.dll 	XPCConvert::NativeInterface2JSObject 	js/src/xpconnect/src/xpcconvert.cpp:1238
2 	xul.dll 	NativeInterface2JSObject 	js/src/xpconnect/src/nsXPConnect.cpp:1175
3 	xul.dll 	nsXPConnect::WrapNative 	js/src/xpconnect/src/nsXPConnect.cpp:1206
4 	xul.dll 	XPCThrower::ThrowExceptionObject 	js/src/xpconnect/src/xpcthrower.cpp:328
5 	xul.dll 	XPCThrower::BuildAndThrowException 	
6 	xul.dll 	XPCThrower::BuildAndThrowException 	js/src/xpconnect/src/xpcthrower.cpp:256
7 	xul.dll 	XPCThrower::Throw 	js/src/xpconnect/src/xpcthrower.cpp:106
8 	xul.dll 	XPCWrappedNativeProto::Init 	
9 	xul.dll 	XPCWrappedNativeProto::GetNewOrUsed 	js/src/xpconnect/src/xpcwrappednativeproto.cpp:264
and so on ...

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=2&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=XPCWrappedNative%3A%3AGetNewOrUsed%28XPCCallContext%26%2C%20xpcObjectHelper%26%2C%20XPCWrappedNativeScope*%2C%20XPCNativeInterface*%2C%20int%2C%20XPCWrappedNative**%29
Crash Signature: [@ XPCWrappedNative::GetNewOrUsed(XPCCallContext&, xpcObjectHelper&, XPCWrappedNativeScope*, XPCNativeInterface*, int, XPCWrappedNative**) ]
(Reporter)

Comment 1

7 years ago
It's #29 top crasher in 8.0 because of startup crashes.

Stack traces are different from the one in comment 0:
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	XPCWrappedNative::GetNewOrUsed 	js/src/xpconnect/src/xpcwrappednative.cpp:379
1 	xul.dll 	nsXPCComponents::AttachNewComponentsObject 	js/src/xpconnect/src/xpccomponents.cpp:4341
2 	xul.dll 	nsXPConnect::InitClasses 	js/src/xpconnect/src/nsXPConnect.cpp:1014
3 	xul.dll 	nsXPConnect::InitClassesWithNewWrappedGlobal 	js/src/xpconnect/src/nsXPConnect.cpp:1191
4 	xul.dll 	mozJSComponentLoader::GlobalForLocation 	js/src/xpconnect/loader/mozJSComponentLoader.cpp:783
...
OS: Windows 7 → Windows XP
Summary: crash[@ XPCWrappedNative::GetNewOrUsed(XPCCallContext&, xpcObjectHelper&, XPCWrappedNativeScope*, XPCNativeInterface*, int, XPCWrappedNative**) ] → Crash in XPCWrappedNative::GetNewOrUsed mainly on Windows XP

Comment 2

7 years ago
In the last week we have 1669 of these on 8.0 (#40) and 1167 on 8.0.1 (#17). Adding the top crash keyword.
Keywords: topcrash

Comment 3

7 years ago
Around 92% of these crashes occur in < 1 min.
Whiteboard: startupcrash

Comment 4

7 years ago
Sitting at #74 on 9.0.1 and #283 on 10.0. Removing the top crash keyword.
Keywords: topcrash

Updated

7 years ago
Summary: Crash in XPCWrappedNative::GetNewOrUsed mainly on Windows XP → startup Crash in XPCWrappedNative::GetNewOrUsed mainly on Windows XP

Comment 5

7 years ago
perhaps bug 487619 is a duplicate. see esp. bug 487619 comment 1
(Reporter)

Comment 6

5 years ago
Let's dupe it to bug 749655, its new signature.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 749655

Updated

2 years ago
See Also: → bug 487619
You need to log in before you can comment on or make changes to this bug.