Closed Bug 603096 Opened 12 years ago Closed 12 years ago

The window moves without user's request

Categories

(Firefox :: General, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 502561

People

(Reporter: ilhan, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101009 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101009 Firefox/4.0b8pre

The windows moves without user's control. the only reason for this is only one tab.

Reproducible: Always

Steps to Reproduce:
1. Go to www.nobrain.dk (NSFW)
2. 
3.
Actual Results:  
Now Firefox window moves to right and left, and back to right and back to left and so on... It is not possible to catch up the close button of the window and the other close buttons.

Expected Results:  
Window should not move. The user should be able to close the other tabs without problem.

If the user is at work and somehow he or she clicks the button then it is possible for him or her to be fired. Thus, "the moving of window" function should be removed.
Summary: The windows moves without user's control → The window moves without user's request
Edit Preferences... under "Content" tab, click "Advanced..." next to
the "Enable JavaScript", uncheck "Move or resize existing windows"
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
I don't think that every Firefox user will be aware of the page here when he or she falls in trap. Most Firefox users are not aware that this option exists. Even if they know they will not uncheck the option before they enter the site.
I think that move part should be unchecked by default as it is in Opera and Chrome. I don't know whether there is an option or not in Opera and Chrome but they do not move the window.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Ok, so you morphed the bug into a request that we change the default.
This is a known problem (since many years) so filing new bugs doesn't
help.  See the dependent bugs on bug 432687.
Bug 186708 and bug 502561 deals with this problem already.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 502561
You need to log in before you can comment on or make changes to this bug.