SVN Account Request - Michel Nédélec <mnedeleg@yahoo.fr>

RESOLVED FIXED

Status

Infrastructure & Operations Graveyard
Account Requests
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: Michel Nédélec, Assigned: jlaz)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101009 Firefox/4.0b8pre
Build Identifier: 

Hi, I'd like to get SVN commit access.  I'm the committer for the breton (br) translation team.  I have a Mercurial account from bug 591616.
 My LDAP account is: mnedeleg@yahoo.fr
 I need write access to the following locations:
   svn.mozilla.org/addons/trunk/site/app/locale/br/
   svn.mozilla.org/projects/mozilla.com/trunk/br/
   svn.mozilla.org/projects/mozilla-europe.org/trunk/br/
 Thanks.

Reproducible: Always
(Reporter)

Comment 1

7 years ago
Created attachment 482079 [details]
My SSH public key
(Assignee)

Updated

7 years ago
Assignee: server-ops → jlazaro
(Assignee)

Updated

7 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
I am vouching for Michel, he should be added to the @localizers group (Michel, being in that group will give you access to all web sites you could localize).
(Assignee)

Comment 3

7 years ago
Added to @localizers, svn bit enabled.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

7 years ago
Does that mean that I should be able to do a commit?
I have tried several times but it doesn't work.

My SSH connection seems to be OK because I can connect to the server:

michel@ubuntu:~$ ssh mnedeleg@yahoo.fr@svn.mozilla.org
( success ( 2 2 ( ) ( edit-pipeline svndiff1 absent-entries commit-revprops depth log-revprops partial-replay ) ) )

I can also do a checkout:

michel@ubuntu:~$ svn --username mnedeleg@yahoo.fr checkout svn+ssh://svn.mozilla.org/projects/mozilla.com/trunk/br
A    br/firefox
A    br/firefox/4beta
A    br/firefox/4beta/firstrun
A    br/firefox/4beta/firstrun/index.html
A    br/includes
A    br/includes/l10n
A    br/includes/l10n/main.lang
A    br/includes/l10n/videos
A    br/includes/l10n/sub-fx4-firstrun-beta.html
Checked out revision 75589.

But I can't commit:

michel@ubuntu:~/br$ svn --username mnedeleg@yahoo.fr commit
Sending        firefox/4beta/firstrun/index.html
Sending        includes/l10n/main.lang
Sending        includes/l10n/sub-fx4-firstrun-beta.html
Transmitting file data ...svn: Commit failed (details follow):
svn: Access denied
svn: Your commit message was left in a temporary file:
svn:    '/home/michel/br/svn-commit.tmp'


I have also tried with HTTPS but it don't work either
Hi Michel, for svn we use https with your ldap account for identification, not svn+ssh. If you have checked the repository with the svn+ssh:// protocol or the http:// protocol, you should do a svn switch to https:// or just check out a new copy using https.

If you can, connect to IRC (irc.mozilla.org) on the #frenchmoz or #l10n channel and we can see all that together ;)
Product: mozilla.org → Infrastructure & Operations
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.