.R script files open as .txt

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
8 years ago
6 years ago

People

(Reporter: solomon.messing, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100915 Lightning/1.0b2 Thunderbird/3.1.4

When I double click on .R files that have been attached to an email to open them, Thunderbird adds a ".txt" extension on them. This is a not a serious bug, but it is a nuisance because when Thunderbird sends them to Notepad++ or Eclipse as .txt files, there is no syntax highlighting. I have to save them, then rename them, then open them. This is most likely an issue for everyone who collaborates using the (open-source) R statistical programming language. Thank you very much!

Reproducible: Always

Steps to Reproduce:
1. Receive email with an .R script (a plain-text file with the .R extension, used with the R statistical programming language)
2. Double click on the attachment.
3. Thunderbird automatically open the file as a .txt file instead of a .R file.
Actual Results:  
File is sent to the os as a txt file. On my system, it opens in a text editor such as Notepad++, but syntax highlighting is lost. Also, it is necessary to rename the file as .R prior to using it.

Expected Results:  
File should open as a .R file.

NA.
That all depends on the mime-type.
Which mime-type is used in the email for this attachment ?
The default file extension for the mime-type is added if you open it in an external application. That is a security and also a functionality function.
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> That all depends on the mime-type.
> Which mime-type is used in the email for this attachment ?
> The default file extension for the mime-type is added if you open it in an
> external application. That is a security and also a functionality function.

The mime type for the attachment is text/plain. Does that mean the problem is not with Thunderbird?

I thought a similar bug existed for .rtf files, and fixing it was not a problem.
Thunderbird calls the helper application that is assigned to text/plain.
It also adds the default extension from the windows registry for that mime-type because some helper application will not work if they don't get the right extension.

You get as example a mail with an attachment application/ms-word and a .word file as extension. It's very likely that MS-Word will refuse such a file with .word as extension. ok, this is not a good example but you should get the idea.
(Reporter)

Comment 4

8 years ago
I think that you are saying that because Thunderbird does not recognize the R mime type, it assigns it to the text/plain mime type. So why not create a mime-type for R files in Thunderbird?
no, the sender client sets the mime-type for an attachment. comment#ß says that you received this mail.

Comment 6

6 years ago
can we close this?
Whiteboard: [closeme 2012-09-15]

Comment 7

6 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2012-09-15]
You need to log in before you can comment on or make changes to this bug.