The preferences menu doesn't open

RESOLVED INCOMPLETE

Status

()

Firefox
Preferences
--
major
RESOLVED INCOMPLETE
8 years ago
8 years ago

People

(Reporter: Jacob, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

Attempting to open the preferences cause Firefox to act like it's not the active window, and no preferences menu opens.  Firefox doesn't crash, it simply does what it should if the preferences menu were to open, but it doesn't.  Minimizing, hiding, or switching to a different program and switching back causes Firefox to act like the active window again, but there's still no preferences menu.

Reproducible: Always

Steps to Reproduce:
1. Try to open the preferences menu, either through the menu system, or the keyboard shortcut.
Actual Results:  
Exactly as described in the details section.

Expected Results:  
The preferences menu should open.

I'm using the default configuration, plus a few incompatible add-ons that are off.  I've re-installed a few time, but I get the same problem everytime.
Can you please create a new profile, http://support.mozilla.com/en-US/kb/managing+profiles, and also, if that does not work, update to beta 7 which will be coming out in a few days.
Version: unspecified → Trunk

Comment 2

8 years ago
Beta 7 doesn't fix it, however creating a new profile will.
Well then this is caused by an extension. Please disable your extensions one by one, and narrow down the cause. Then report to the extension developer.

Comment 4

8 years ago
For reference, my issue was caused by the no longer maintained FireGPG. 
Thank you Tyler.
Thanks for your feedback. When it is not maintained anymore we should probably close this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: Menus → Extension Compatibility
QA Contact: menus → extension.compatibility
Resolution: --- → INVALID
Summary: The preferences menu doesn't open → The preferences menu doesn't open [caused by FireGPG]
(Reporter)

Comment 6

8 years ago
If this is caused by an add-on, then the only option is the feedback add-on, since that's all I have right now, but it can't be that either, since I disabled it too.  I think this needs another look at.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Updated

8 years ago
Summary: The preferences menu doesn't open [caused by FireGPG] → The preferences menu doesn't open
Jacob, does this happen in a fresh profile?
(Reporter)

Comment 8

8 years ago
Sorry, I meant to add that, no, adding a new profile fixed the problem.
Ok, so please check the user preferences in the troubleshooting page which could enlighten us here.
Component: Extension Compatibility → Preferences
QA Contact: extension.compatibility → preferences
(Reporter)

Comment 10

8 years ago
Neither running in safe mode nor resetting my preferences worked, only making a new profile or a clean reinstall could fix the problem.
Please make a backup of this profile and start to delete files while Firefox doesn't run. one of the existing files should be the cause.
(Reporter)

Comment 12

8 years ago
Well I already did a clean install, so neither of my original profiles, default or the second one, exist anymore.
So whenever you can reproduce this issue feel free to reopen. Closing this bug because of missing information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 14

8 years ago
Fine with me
You need to log in before you can comment on or make changes to this bug.