[D3D9] Canvas is not painted if WebGL pages open on 2 tabs with ATI OpenGL renderer

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Alice0775 White, Assigned: bjacob)

Tracking

({regression})

Trunk
mozilla2.0
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [softblocker], URL)

(Reporter)

Description

8 years ago
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101009 Firefox/4.0b8pre ID:20101009041646

When I open two tabs, one is http://learningwebgl.com/lessons/lesson01/index.html , and the other is http://www.iquilezles.org/apps/shadertoy/ ,

Canvas is not painted.
Reload the page, then the canvas is painted


Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open http://learningwebgl.com/lessons/lesson01 
3. Open URL in new tab ( http://www.iquilezles.org/apps/shadertoy/ )


Actual Results:
 Canvas is not painted.

Expected Results:
 Canvas shoud be painted.
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
(Reporter)

Comment 1

8 years ago
Regression window (cashed m-c hurly build) Set webgl.enabled_for_all_sites to true :
Works:
http://hg.mozilla.org/mozilla-central/rev/83e9c68be99d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100903 Firefox/4.0b6pre ID:20100903181322
Fails:
http://hg.mozilla.org/mozilla-central/rev/2fd612733112
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100902 Firefox/4.0b6pre ID:20100903210645
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=83e9c68be99d&tochange=2fd612733112
Keywords: regression
(Reporter)

Updated

8 years ago
Summary: Canvas is not painted → Canvas is not painted if WebGL pages open on 2 tabs.
(Assignee)

Comment 2

8 years ago
This sounds awfully like a gl-function-called-on-wrong-context bug. Once bug 597881 is landed, in a debug build, running with the environment variable MOZ_GL_DEBUG=1, we'll get a nice crash when this happens. I'll try to reproduce.
(Reporter)

Comment 3

8 years ago
if set  layers.accelerate-all to false, the problem does not happen.
So, Comment #1 is only pointed out about D3D9 on/off.

Comment 4

8 years ago
Here are the graphic details from Alice0775 :

Adapter Description: ATI Radeon HD 4300/4500 Series ---- Actually I use HD4350
Vendor ID: 1002
Device ID: 954f
Adapter RAM: 512
Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32
atiumdva atiumd6a atitmm64
Driver Version: 8.771.0.0
Driver Date: 8-25-2010
Direct2D Enabled: true
DirectWrite Enabled: true
GPU Accelerated Windows: 2/2 Direct3D 9
Component: Canvas: WebGL → Graphics
QA Contact: canvas.webgl → thebes
Summary: Canvas is not painted if WebGL pages open on 2 tabs. → [D3D9] Canvas is not painted if WebGL pages open on 2 tabs
Assignee: nobody → bjacob
blocking2.0: ? → final+
(Assignee)

Comment 5

8 years ago
Can you please check if you can still reproduce?

I can't reproduce. MOZ_GL_DEBUG doesn't say anything, even with many WebGL tabs. With and without GL layers.
(It's especially likely to no longer happen because we render WebGL using ANGLE now.)
Whiteboard: [soft blocker]
Whiteboard: [soft blocker] → [softblocker]
(Reporter)

Comment 7

8 years ago
This was fixed if installed the DirectX runtime (
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&displaylang=en
) i.e. This was fixed if ANGLE is used.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110118
Firefox/4.0b10pre ID:20110118030327
  Graphics
        Adapter Description: ATI Radeon HD 4300/4500 Series
        Vendor ID: 1002
        Device ID: 954f
        Adapter RAM: 512
        Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64
atiumdag atidxx32 atiumdva atiumd6a atitmm64
        Driver Version: 8.801.0.0
        Driver Date: 
        Direct2D Enabled: true
        DirectWrite Enabled: true
        WebGL Renderer: TransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel
Jan 13 2011 03:37:36)
        GPU Accelerated Windows: 1/1 Direct3D 10
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 8

8 years ago
> This was fixed if installed the DirectX runtime
It is not fixed for users that don't install it as it is not provided by Mozilla.
So I reopen it.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: [D3D9] Canvas is not painted if WebGL pages open on 2 tabs → [D3D9] Canvas is not painted if WebGL pages open on 2 tabs with ATI OpenGL renderer
We ship it now! hooray!
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.