Wikipedia's mobile site is unreadable

VERIFIED FIXED in Nov

Status

Tech Evangelism Graveyard
English Other
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: stechz, Assigned: aakashd)

Tracking

unspecified
All
Android

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
It has small text with a full-size viewport with columns that are the width of the viewport.
I can reproduce this on Android, but not on desktop Linux.  It looks like Wikipedia's mobile site sends different markup to Fennec on Android.  On desktop I see this:

<meta name = "viewport" content = "width=device-width; initial-scale=1.0; maximum-scale=1.0; user-scalable=0;" />

But on Android there is no meta[name="viewport"] element.
(Assignee)

Comment 2

7 years ago
This should block 2.0 since it's a default search option
tracking-fennec: --- → ?
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> This should block 2.0 since it's a default search option

If Matt is right, there's nothing we can really do about this except get in touch with Wikipedia or remove it as a search option.
My contact at Wikipedia is forwarding this along to the right people.  Will report back when I have an update.
Assignee: nobody → english-us
Component: General → English US
Product: Fennec → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified
Assignee: english-us → nobody
Component: English US → General
Product: Tech Evangelism → Fennec
QA Contact: english-us → general
Target Milestone: --- → fennec2.0
Version: unspecified → Trunk

Comment 5

7 years ago
Shouldn't this stay in TE, then, since it's really a Wikipedia bug and not a Fennec bug?
(In reply to comment #5)
> Shouldn't this stay in TE, then, since it's really a Wikipedia bug and not a
> Fennec bug?

We want this to be fixed and if we can do something to fix it, we should. I'm afraid TE is a black hole of FAIL.

Matt - Is this a "Android 2.x" UA issue?
Target Milestone: fennec2.0 → ---
Assignee: nobody → mbrubeck
tracking-fennec: ? → 2.0b3+
Target Milestone: --- → fennec2.0

Comment 7

7 years ago
(In reply to comment #6)
> (In reply to comment #5)
> > Shouldn't this stay in TE, then, since it's really a Wikipedia bug and not a
> > Fennec bug?
> 
> We want this to be fixed and if we can do something to fix it, we should. I'm
> afraid TE is a black hole of FAIL.

Not if someone actually owns the bug and is willing to work on it. :) The biggest problem TE has is lack of resources to evangelise. If you -- or others on the Fennec team -- are willing to be point people on this, it'll get fixed, barring total obstinacy on the part of Wikipedia.

cl
(In reply to comment #7)
> it'll get fixed, barring total obstinacy on the part of Wikipedia.

That's my concern

Comment 9

7 years ago
(In reply to comment #8)
> (In reply to comment #7)
> > it'll get fixed, barring total obstinacy on the part of Wikipedia.
> 
> That's my concern

With all due respect, I don't think Wikipedia's inclination to fix this or not has anything to do with what component of Bugzilla the bug is filed in. :-p

cl
(In reply to comment #9)
> (In reply to comment #8)
> > (In reply to comment #7)
> > > it'll get fixed, barring total obstinacy on the part of Wikipedia.
> > 
> > That's my concern
> 
> With all due respect, I don't think Wikipedia's inclination to fix this or not
> has anything to do with what component of Bugzilla the bug is filed in. :-p

Indeed, and you can create a clone of this in TE. It doesn't remove the fact we still may need to do something in product to fix this. Putting this bug in a component that core developers do not track will remove it from the "radar", which I don't want.
Duplicate of this bug: 605543
Created attachment 488272 [details]
screen shot

this is what I see
Depends on: 604765
in content.js viewportScale is NaN, which is why we're not laying this out correctly
m.wikipedia.com has this for a viewport meta tag:
<meta name = "viewport" content = "width=device-width; initial-scale=1.0; maximum-scale=1.0; user-scalable=0;" />

howver, windowUtils.getDocumentMetadata("viewport-initial-scale") is returning an empty string. Something is broken here.
(In reply to comment #14)
> m.wikipedia.com has this for a viewport meta tag:
> <meta name = "viewport" content = "width=device-width; initial-scale=1.0;
> maximum-scale=1.0; user-scalable=0;" />
> 
> howver, windowUtils.getDocumentMetadata("viewport-initial-scale") is returning
> an empty string. Something is broken here.

That might be fixed by bug 572696, which was just pushed a few hours ago.
(In reply to comment #15)
> (In reply to comment #14)
> > m.wikipedia.com has this for a viewport meta tag:
> > <meta name = "viewport" content = "width=device-width; initial-scale=1.0;
> > maximum-scale=1.0; user-scalable=0;" />
> > 
> > howver, windowUtils.getDocumentMetadata("viewport-initial-scale") is returning
> > an empty string. Something is broken here.
> 
> That might be fixed by bug 572696, which was just pushed a few hours ago.

turns out wikipedia isn't giving us the viewport meta tag on android. It gives it to us on desktop and we handle it correctly, so this sounds like an evangelism bug now.
Assignee: mbrubeck → english-us
Component: General → English US
Product: Fennec → Tech Evangelism
QA Contact: general → english-us
Target Milestone: fennec2.0 → ---
Version: Trunk → unspecified
Let's remove wikipedia from the search list until nicer content is available for us.
Kev - Would this fall under your realm of influence? Can we reach out to the folks at Wikipedia to get send Fennec consistent content?
We have choices for content:
* Full web site (http://en.wikipedia.org)
* Plain mobile web site (http://mobile.wikipedia.org)
* Enhanced mobile web site (http://en.m.wikipedia.org)

I think we want the enhanced mobile web site as a default for Fennec. However, we still have a problem:

If you visit http://en.m.wikipedia.org in Fennec on Maemo or Desktop, you'll get a page that has a <meta name="viewport"> element and uses /stylesheets/default.css

If you visit http://en.m.wikipedia.org in Fennec on Android, you'll get the same content, but there is no <meta name="viewport"> tag and /stylesheets/android.css is used.

The missing viewport meta tag causes the zooming problem. The android.css has some webkit specific CSS in it.

If Wikipedia could always send the <meta name="viewport"> use default.css, the content would look optimum in Fennec.

Updated

7 years ago
Assignee: english-us → nobody
Component: English US → General
Product: Tech Evangelism → Fennec
QA Contact: english-us → general
Version: unspecified → Trunk

Updated

7 years ago
tracking-fennec: 2.0b3+ → ---

Updated

7 years ago
Assignee: nobody → english-other
Component: General → English Other
Product: Fennec → Tech Evangelism
QA Contact: general → english-other
Target Milestone: --- → Nov
Version: Trunk → unspecified
(Assignee)

Comment 20

7 years ago
I'm talking to the folks at wikipedia and they're going to url sniff for fennec and show us their iphone site; will update when it's done.
Assignee: english-other → mozaakash
This was fixed by Wikipedia.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 22

7 years ago
Yep, going over to en.m.wikipedia.org shows the iphone version on fennec nightlies now.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.