If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

'Place replies in folder' sent messages makes Thunderbird think it is a new e-mail, and alerts

RESOLVED WORKSFORME

Status

Thunderbird
Untriaged
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: Tyler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.9) Gecko/20100915 Lightning/1.0b2 Thunderbird/3.1.4

When making use of the sent message copy feature (i.e. under Account Settings > Copies & Folders > check "Place replies in the folder of the message being replied to") Thunderbird will "discover" the copy and alert you that there is a new message. Obviously this isn't the case as it's just a copy of the sent message. 

There should be some way for Thunderbird to recognize that it created the copy and not alert you of 'new mail' when there actually isn't any.

Reproducible: Always

Steps to Reproduce:
1. Check "Place replies in the folder of the message being replied to"
2. Reply to a message
3. Watch as Thunderbird notifies you of a new message (the copy)
Actual Results:  
Thunderbird erroneously notified me that I had new mail when I didn't.

Expected Results:  
Not to be notified of new mail, but to still have the copy in my inbox.
Assuming you are talking about the alert in the system tray, I can't reproduce this with imap running Mozilla/5.0 (Windows NT 6.0; rv:2.0b8pre) Gecko/20101008 Thunderbird/3.3a1pre

are you very certain about this behavior not being impacted by a different account getting new mail, or the account getting new mail in some other folder? Is the sent copy in the folder being saved as a new message, or an unread message? (sent messages should be status=unread)
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Assuming you are talking about the alert in the system tray, I can't reproduce
> this with imap running Mozilla/5.0 (Windows NT 6.0; rv:2.0b8pre) Gecko/20101008
> Thunderbird/3.3a1pre

The system tray and the audio notification both occur. I have 7 e-mail accounts in my Thunderbird setup and I can confirm that this bug does happen with one of my IMAP accounts.

> are you very certain about this behavior not being impacted by a different
> account getting new mail, or the account getting new mail in some other folder?

Positive. The only "new mail" I'm getting is the copy of my sent message that is saved into my inbox. If there is other unread mail it also re-displays the notifications for all of them as well.

> Is the sent copy in the folder being saved as a new message, or an unread
> message? (sent messages should be status=unread)

It is the copy that is being saved to the folder. It is saved as a read message but this doesn't seem to matter to Thunderbird. In fact the only way to 'trick' it into acknowledging the (already 'read') copy and remove the notification is to click on the specific inbox of the e-mail account that sent the message (as opposed to the unified main inbox).

As you can imagine it is rather frustrating to have to constantly change from the unified inbox to the account inbox every time I send a new e-mail just to remove the notification. 

Please let me know if I can help in any other way by providing more data/testing use cases.
Joe, can you produce this?

I think I see this, but not consistently. 
asked http://forums.mozillazine.org/viewtopic.php?f=31&t=2034491

Comment 4

7 years ago
Not able to reproduce here with 2 pop3 accounts (no imap)
Tested with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2.13pre) Gecko/20101108 Lanikai/3.1.7pre ID:20101108231558
Also 3.3

Comment 5

7 years ago
I can confirm this with Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.15) Gecko/20110303 Thunderbird/3.1.9. I'm using 3 IMAP accounts. Note that I use the MagicSLR addon to send via the local Outbox and the Blunderdelay addon to actually send the message.

What happens is that the account name turns blue and shows the star for "new message". The inbox stays normal (not bold, no unread messages count). And indeed, by reselecting the Inbox, the status is updated correctly (if the inbox was allready selected, first a different folder has to be selected).
Whiteboard: [dupeme]
Component: General → Untriaged
Herre,
Tyler,

Do you still see this?
(guessing you do, but need to re-check)
Flags: needinfo?(tyler)
Flags: needinfo?(tb4)
Summary: 'Place replies in folder' sent messages makes Thunderbird think it is a new e-mail → 'Place replies in folder' sent messages makes Thunderbird think it is a new e-mail, and alerts
(Reporter)

Comment 7

4 years ago
(In reply to Wayne Mery (:wsmwk) from comment #6)
> Herre,
> Tyler,
> 
> Do you still see this?
> (guessing you do, but need to re-check)

I no longer see this issue.
Flags: needinfo?(tyler)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(tb4)
Resolution: --- → WORKSFORME

Comment 8

4 years ago
I couldn't reproduce it yesterday (on Windows 7), but it just happened again (on OS X).
You need to log in before you can comment on or make changes to this bug.