"href" and "src" lose part of their url path

RESOLVED WORKSFORME

Status

SeaMonkey
Composer
--
major
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Bart, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Chrome/6.0.472.63 Safari/534.3
Build Identifier: 2.0.8

After working in the <HTML>Source, and switching to Normal mode, the "href" and "src" may loose the first part of the url-path. This means for example that the CSS-file may not be found and becomes inaccessible. Or... that images are not visible anymore, because part of the url has been skipped and is missing. 

A similar problem has been reported several times by Composer-users for the loss of the "width" and "height" attributes of images, making images to return to their original size. 

It applies to the last versions of Composer, starting from 2.0.

In my opinion the problems will not be found in the earlies versions 1.1.19 (possibly) and 1.1.18 (definitely).



Reproducible: Sometimes

Steps to Reproduce:
1.Open a webpage with a CSS-file and some images (in Composer)
2.Switch to <HTML>Source-mode, change something in the source-code, and return to Normal mode (several times)

Actual Results:  
What happens quite often (after several times of switching between Source and Normal Mode) is loss of CSS-quality, and images go blank.  

Expected Results:  
The software should keep the path of url (href and src) intact and unchanged. The same applies for width and height characteristics of images. 

A similar problem has been reported several times by Composer-users for the loss of the "width" and "height" attributes of images (after working in <HTML>Source), making images return with every swith (to Normal mode) to their original size. This problem - as far as I know -  has been a constant failure of all the builds from 2.0 of Seamonkey.

The combined problems with Composer in the new versions of Seamonkey are so serious that I have decided to return to 1.1.18 (because Composer for me is the main attraction of Seamonkey).

Comment 1

6 years ago
I've not seen this on 2.2, do you have a test which demonstrates the issue that you could attach?

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.