Closed Bug 603229 Opened 9 years ago Closed 9 years ago

Prefs UI is not initialized when Fennec is launched with an image URI

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mbrubeck, Assigned: mbrubeck)

References

()

Details

Attachments

(1 file, 1 obsolete file)

Steps to reproduce:
1. Launch Fennec with an image URL, for example "fennec http://bit.ly/akf4Fn"
2. Open the tool panel by pressing the gear icon on the right toolbar.

Results: The add-on manager is empty, the Sync UI is non-functional, the error console does function, etc.

All these components are usually initialized when the first page loads, but we don't fire DOMContentLoaded after loading an image.
Attached patch init on pageshow (obsolete) — Splinter Review
Using the "pageshow" event instead of DOMContentLoaded fixes the problem.  Are there any potential side effects to this?
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Attachment #482168 - Flags: review?(mark.finkle)
(In reply to comment #1)
> Created attachment 482168 [details] [diff] [review]
> init on pageshow
> 
> Using the "pageshow" event instead of DOMContentLoaded fixes the problem.  Are
> there any potential side effects to this?

I just thought of a problem. "about:blank" fires "pageshow" too which means we will delayInit the browser tools ealier and Ts will be affected
Comment on attachment 482168 [details] [diff] [review]
init on pageshow

We need to check the URI, like we do in browser-chrome tests. We need to ignore any "pageshow" for "about:blank". That should make it work without affecting Ts.
Attachment #482168 - Flags: review?(mark.finkle) → review-
Attached patch patch v2Splinter Review
Add a check for about:blank
Attachment #482168 - Attachment is obsolete: true
Attachment #482169 - Flags: review?(mark.finkle)
Comment on attachment 482169 [details] [diff] [review]
patch v2

Let's just keep an eye on Ts in case we missed something.
Attachment #482169 - Flags: review?(mark.finkle) → review+
Pushed: http://hg.mozilla.org/mobile-browser/rev/6eadac9795e4

Looks like Ts is the same after this push.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Marked as verified for Pref UI

Mozilla/5.0 (Maemo;Linux armv71; rv:2.0b8pre)Gecko/20101012 Firefox/4.0b8pre Fennec/4.0b2pre
Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101012 Firefox/4.0b8pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.