Perform sanity check of server names when migrating them

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
18 years ago
11 years ago

People

(Reporter: mpt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
To reproduce:
* In 4.x, try to connect to a news server which you do not have access to,
  because of a firewall or whatever. (I'm not sure that this is how this
  happened, but it seems the most plausible scenario.)
* Months or years later, start up Mozilla, migrating your 4.x profile.
* Open the Messenger three-pane window, and look in the folder pane.

What you should see:
* Your migrated mail and news accounts.

What you actually see:
* Your migrated mail and news accounts, plus a phantom news server which has no
  name and has no subscribed groups.
* When the phantom server is selected, ugliness which looks approximately like
  `|<- - Mozilla' appears in the title bar of the three-pane window.

This appears to be the culprit, the last few lines of my 4.x NewsFAT file:
------
	FALSE
	FALSE
	FALSE
	FALSE
	
	FALSE
	FALSE
	FALSE
snewsrc-
	
	FALSE
------

Updated

18 years ago
QA Contact: gbush → laurel
migration -> racham.
Assignee: sspitzer → racham
mass re-assign.
Assignee: racham → sspitzer
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".
OS: Mac System 8.5 → All
Hardware: Macintosh → All
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
as with bug 45777...
->WONTFIX since 4.x migation has been dropped on trunk. 

If one has an overwhelming need to see this fixed on branch, please attach a patch and reopen the bug.  Also, evaluate whether the issue is a bug or an enhancement request and adjust severity accordingly.
filter bugmail for "4.xmidrop" to delete these messages.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

11 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.