Firefox hangs 100% cpu during page refresh with certain content (example given)

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Jonty, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Chrome/6.0.472.63 Safari/534.3
Build Identifier: 3.6.10

One of the Firefox threads goes into an infinite loop during reload of certain video content displayed using flash. Note that it is a firefox thread that hangs, not the plugin container.

Reproducible: Always

Steps to Reproduce:
1.Load the given example page then refresh it with ctrl-f5
2.
3.
Actual Results:  
One of the firefox threads loops infinitely


Attached is the test page used. It was extracted from failblog.org and is typical of their page content (with all extraneous stuff removed). Note that the fact that there are two objects on the page seems to be important. Refreshing this page with ctrl-f5 hits the problem every time on my system. With the original failblog.org page it is more variable (probably because the content varies) and also occurs when clicking on refresh tab.

Also attached is configuration information on plugins and extensions.
(Reporter)

Comment 1

7 years ago
Created attachment 482209 [details]
Test case
(Reporter)

Comment 2

7 years ago
Created attachment 482210 [details]
thread and stack info via process explorer
(Reporter)

Comment 3

7 years ago
Created attachment 482211 [details]
plugins and extensions info
The Testcase is working fine here with Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.11) Gecko/20101001 Firefox/3.6.11 and Adobe Flash 10.2.161.23, even if I start playing both Videos before reloading them.

Is the Issue reproduceable in Safe-Mode/extension-less?
Is that the only Site you experienced the Issue?
Severity: major → normal
Version: unspecified → 3.6 Branch
no crash with Seamonkey trunk and Flash 10.1 r85
(Reporter)

Comment 6

7 years ago
OK, I have been through the extensions disabling dance and it turns out to be an interaction with Firebug, but specifically version 1.3.3

For some reason the automatic update of Firebug wasn't working, and when I asked for a manual update it gave an error. I have now installed the latest version (1.5.4) and this problem no longer occurs.

Thanks for the help and sorry to have failed to spot the Firebug interaction before posting the bug report.

I have set the status to "resolved/invalid".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.