OS/2 - Content of comboboxes display when printing

VERIFIED FIXED

Status

()

Core
Printing: Output
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Barry Marshall (at work), Assigned: mkaply)

Tracking

Trunk
Other
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(11 attachments)

(Reporter)

Description

18 years ago
OS/2 1114, TP 770x, WSeB, SDD, fresh install, Faxworks Pro for OS/2 3 with all
latest public fixes applied.

When attempting to print www.mozilla.org, the insides of tables appear as black
boxes and can not be read.

Printing the same page under NS/2 4.61 yields viewable results.

Also, unlike 4.61, the filename and http location aren't printed at the top of
the page.  This can be both a good or a bad thing, so it would be nice if this
was an option that could be setup before a job was printed.  The printing dialog
box dones't allow for the setting of this option.

Since I'm on remote today, I don't have another printer I can use to see if this
is a Mozilla and/or an Warpzilla problem.

Pictures to be attached of the output.
(Reporter)

Comment 1

18 years ago
Created attachment 19322 [details]
NS/2 4.61 Output
(Reporter)

Comment 2

18 years ago
Created attachment 19323 [details]
Warpzilla 1114 Output
(Reporter)

Comment 3

18 years ago
Okay, output is much better now under 1201.  The text is visible now.

The next problem with this page is that it's being split over several pages,
which doesn't really make sense.  I'd expect everything to either be on the same
page or be broken at some point in the middle and continue down from there.

Sample output to follow.
(Reporter)

Comment 4

18 years ago
Created attachment 20042 [details]
OS/2 1201 output - page 1
(Reporter)

Comment 5

18 years ago
Created attachment 20044 [details]
OS/2 1201 output - Page 2
(Reporter)

Comment 6

18 years ago
Created attachment 20045 [details]
OS/2 1201 - Page 3

Comment 7

18 years ago
In addition, try printing off http://www.retrogames.com.

For some reason, printing this site kicks off two seperate print jobs - one with
the contents of the banner ad, the other without.  Again, I'd expect to see this
on the same page.

The console says:

Got surface of size 1626 x 2058 pixels
mPixelScale = 2.130315
BeginDoc
EndDoc
BeginDoc
NewPageNewPageNewPageEndDoc

This is also harder to read than the NS/2 4.61 version of the output.

What would be really nice is if there was some sort of printing gamma adjustment
 to make sites like this a little more readable... esp. when dealing with
colours like blue on black.

Comment 8

18 years ago
Created attachment 20053 [details]
www.retrogames.com - NS/2 4.61 Output

Comment 9

18 years ago
Created attachment 20054 [details]
www.retrogames.com - First print job from Mozilla 1201 - Just the banner ad

Comment 10

18 years ago
Created attachment 20055 [details]
www.retrogames.com - Second print job from 1201 - The rest of the print job

Comment 11

18 years ago
And also try printing
http://www.quicken.com/investments/charts/?symbol=ibm&othersymbols=&mavg=NONE&period=1YEAR&ImgSiz=450x250.

You can see the contents of the drop-down listbox, even if they're closed up.
It also propagates onto the following pages.

Comment 12

18 years ago
Created attachment 20056 [details]
www.quicken.com - Drop-down listboxes show all contents - page 1

Comment 13

18 years ago
Created attachment 20057 [details]
www.quicken.com - Drop-down listboxes from previous page show up again on this page  (page 2)

Updated

18 years ago
Depends on: 62125
(Assignee)

Comment 14

18 years ago
Barry,
could you check the mozilla.org on three pages with faxworks on the latest 
build?

I think it was the same thing that was breaking sidebar.

We're working on the combobox problem.
(Reporter)

Comment 15

18 years ago
Okay, the Mozilla home page now prints like 4.61 with everything on the same
page on 1213.

The Quicken dropdown listbox problem persists the same as before.

Comment 16

18 years ago
Barry is this still a problem in the latest nightly builds?
(Assignee)

Comment 17

18 years ago
This is definitely a valid bug and we are trying to figure out why it only 
happens on OS/2
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: OS/2 - Printing problems when using Faxworks Pro for OS/2 → OS/2 - Content of comboboxes display when printing

Comment 18

18 years ago
*** Bug 66481 has been marked as a duplicate of this bug. ***

Comment 19

18 years ago
spam : changing qa to sujay (new qa contact for Printing)
QA Contact: shrir → sujay
(Assignee)

Comment 20

18 years ago
Created attachment 26968 [details] [diff] [review]
On windows, 0,0 cliprect is an empty rect, not NULL
(Assignee)

Comment 21

18 years ago
Fix checked in
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 22

18 years ago
Barry/Michael, please verify and mark this one verified fixed...thanks.

Comment 23

18 years ago
2nd request:

Barry/Michael, please verify and mark this one verified fixed...thanks.
(Assignee)

Comment 24

18 years ago
We can't verify this yet because I don't have a new OS/2 nightly out for Barry.

I'll put one out tomorrow.

For now, changing QA contact to me.
QA Contact: sujay → mkaply
(Assignee)

Comment 25

17 years ago
This is fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.