Last Comment Bug 603332 - Missing preferences that cause support problems in about:support (Troubleshooting Information)
: Missing preferences that cause support problems in about:support (Troubleshoo...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 10
Assigned To: Tobias (:Tobbi) Markus
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-11 07:24 PDT by Matthew Middleton (:zzxc)
Modified: 2011-11-08 01:14 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.x+


Attachments
patch (990 bytes, patch)
2011-06-06 14:09 PDT, Tobias (:Tobbi) Markus
no flags Details | Diff | Splinter Review
patch v2 (914 bytes, patch)
2011-06-06 14:19 PDT, Tobias (:Tobbi) Markus
gavin.sharp: review-
Details | Diff | Splinter Review
patch v3 (857 bytes, patch)
2011-06-06 14:34 PDT, Tobias (:Tobbi) Markus
gavin.sharp: review+
Details | Diff | Splinter Review

Description Matthew Middleton (:zzxc) 2010-10-11 07:24:07 PDT
The about:support troubleshooting information doesn't include the middle mouse button preferences, which has been a problem for users troubleshooting why autoscrolling or mousewheel scrolling/zooming are not working.

The preferences that should be added are:
mousewheel.* (currently whitelisted incorrectly as browser.mousewheel.*)
general.autoScroll
Comment 1 Matthew Middleton (:zzxc) 2010-12-30 14:59:43 PST
Other preferences that are missing:
permissions.default.image (controls when images are displayed on web sites)
browser.display.* (controls whether colors and background images are used)
services.sync.* (controls whether preferences are synced via Firefox Sync)
Comment 2 Mike Beltzner [:beltzner, not reading bugmail] 2011-01-03 10:53:05 PST
Nice to have, and AIUI can also be added in a stability and support release. Not a blocker for Firefox 4.
Comment 3 Tobias (:Tobbi) Markus 2011-06-06 14:09:39 PDT
Created attachment 537639 [details] [diff] [review]
patch

This patch changes the order of the preferences so that it's alphabetical,
changes browser.mousewheel to mousewheel and adds all the proposed preferences to the whitelist
Comment 4 Tobias (:Tobbi) Markus 2011-06-06 14:19:26 PDT
Created attachment 537643 [details] [diff] [review]
patch v2
Comment 5 Tobias (:Tobbi) Markus 2011-06-06 14:20:04 PDT
Comment on attachment 537643 [details] [diff] [review]
patch v2

Review of attachment 537643 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-06-06 14:24:08 PDT
Comment on attachment 537643 [details] [diff] [review]
patch v2

services.sync.* includes tons of private information (lastSyncTime, "GUID", clusterURL, etc.), so we shouldn't include it here. If there are things there that need to be specifically included we can do that. The other changes look fine.
Comment 7 Tobias (:Tobbi) Markus 2011-06-06 14:34:34 PDT
Created attachment 537647 [details] [diff] [review]
patch v3

v3, excluding services.sync. 

I suppose we can decide on what sync preferences to include later. But for now, this should be everything.
Comment 8 Tobias (:Tobbi) Markus 2011-11-04 04:26:50 PDT
Can someone check this in, please?
Comment 9 Ed Morley [:emorley] 2011-11-04 14:47:35 PDT
Please could you tweak your hgrc to automatically add author info (guide here: http://blog.bonardo.net/2010/06/22/so-youre-about-to-use-checkin-needed) + add a commit message when attaching patches, since it makes pushing half a dozen checkin-neededs a lot easier. Thanks :-)
Comment 10 Ed Morley [:emorley] 2011-11-07 17:53:44 PST
Made the comment 9 changes in the end, just so this manages to make Firefox 10, for SUMO's sake.

https://hg.mozilla.org/integration/mozilla-inbound/rev/a15e40c515eb
Comment 11 Ed Morley [:emorley] 2011-11-08 01:14:25 PST
https://hg.mozilla.org/mozilla-central/rev/a15e40c515eb

Note You need to log in before you can comment on or make changes to this bug.