[document.layers] Cannot navigate to other hidden "tabs" created with "div" element

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P3
normal
VERIFIED FIXED
18 years ago
3 years ago

People

(Reporter: Brent, Assigned: bc)

Tracking

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20001114
BuildID:    2000111420

On main frame (http://www.k-statesports.com/headlines/index.html) of site, it
creates "tabs" for news headlines of each sport.  However, clicking on the tabs
will not show them.  The page is created with "div" element and hides the info
on other tabs.

Reproducible: Always
Steps to Reproduce:
Load page and try to click to a different tab that isn't the default to show.

Actual Results:  Nothing...it doesn't behave as intended.

Expected Results:  It should show the news headlines on the other tabs.  In
other words it should make the tab you click on "active" or visible and hide the
others.
The page uses the following Javascript function to get the div objects:

function MM_findObj(n, d) { //v3.0
  var p,i,x;  if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length)
{
    d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}
  if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++)
x=d.forms[i][n];
  for(i=0;!x&&d.layers&&i<d.layers.length;i++)
x=MM_findObj(n,d.layers[i].document); return x;
}

This function assumes that a browser supports either document.layers or
document.all.  Mozilla supports neither, since both are non-standard.  The
function should be updated to use the W3C DOM function getElementByID.

Over to evangelism, updating summary.
Assignee: clayton → blakeross
Status: UNCONFIRMED → NEW
Component: HTML Element → Evangelism
Ever confirmed: true
QA Contact: lorca → zach
Summary: Cannot navigate to other hidden "tabs" created with "div" element → [document.layers] Cannot navigate to other hidden "tabs" created with "div" element

Comment 2

18 years ago
This is the standard Macromedia Dreamweaver function to find objects in pages.

Maybe someone should "evangelize" the people at Macromedia to release an update 
for this function for existing DWs??? I have patched this function where I work 
so it can find objects using the DOM also (works great in Mozilla and in 
Konqueror).

Updated

18 years ago
Assignee: blakeross → evangelism

Comment 3

18 years ago
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.

Comment 4

18 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary

Comment 5

17 years ago
fixed!
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 7

17 years ago
Verified
2002022703/WinXP
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.