Last Comment Bug 603417 - Blacklist out of process Java plugins on Windows
: Blacklist out of process Java plugins on Windows
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Jim Mathies [:jimm]
:
Mentors:
Depends on:
Blocks: 555699
  Show dependency treegraph
 
Reported: 2010-10-11 11:56 PDT by Jim Mathies [:jimm]
Modified: 2010-10-26 08:08 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
beta8+


Attachments
patch (948 bytes, patch)
2010-10-14 13:57 PDT, Jim Mathies [:jimm]
no flags Details | Diff | Splinter Review
patch (1.92 KB, patch)
2010-10-14 14:54 PDT, Jim Mathies [:jimm]
benjamin: review+
jaas: review+
Details | Diff | Splinter Review
updated patch (3.01 KB, patch)
2010-10-15 09:00 PDT, Jim Mathies [:jimm]
no flags Details | Diff | Splinter Review

Description Jim Mathies [:jimm] 2010-10-11 11:56:18 PDT
Due to various issues with ui created by 3rd party java processes it's been suggested that we should just disable OOPP for java.
Comment 1 Boris Zbarsky [:bz] 2010-10-11 12:01:01 PDT
That means Java crashes will take the browser down, right?  Is that a smaller problem?
Comment 2 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2010-10-11 12:14:47 PDT
Not exactly: the java plugin actually runs its own separate Java process, so the crashes we might experience are only the ones in the plugin, not in all of java. It's a smaller surface area, and we're less exposed to instability in java itself.
Comment 3 Jim Mathies [:jimm] 2010-10-11 12:21:43 PDT
I seriously doubt the java footprint in general is very large. I rarely run into applets anymore.
Comment 4 Justin Dolske [:Dolske] 2010-10-11 16:33:14 PDT
(In reply to comment #2)
> Not exactly: the java plugin actually runs its own separate Java process, so
> the crashes we might experience are only the ones in the plugin, not in all of
> java.

Maybe a dumb question, but does the Java plugin actually deal gracefully when its subprocess crashes?
Comment 5 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2010-10-12 08:30:05 PDT
I don't know, can you kill some java and find out?
Comment 6 Nochum Sossonko [:Natch] 2010-10-12 08:42:59 PDT
(In reply to comment #3)
> I seriously doubt the java footprint in general is very large. I rarely run
> into applets anymore.

AFAIK there are quite a few high-profile games online that use Java. Also, dell uses Java as does NVidia (just to name a few high-profile sites) as a replacement for activeX.
Comment 7 Jim Mathies [:jimm] 2010-10-14 13:57:21 PDT
Created attachment 483263 [details] [diff] [review]
patch

This only blacklists the latest. Apparently there are multiple version of this file, all with different dll names.

http://processlist.com/info/jpinsp.html

I wonder how many of these we should be adding. This patch takes care of updated installs.
Comment 8 Jim Mathies [:jimm] 2010-10-14 14:54:33 PDT
Created attachment 483294 [details] [diff] [review]
patch
Comment 9 Josh Aas 2010-10-15 08:29:00 PDT
Comment on attachment 483294 [details] [diff] [review]
patch

Looks OK, but we already assume that 'aPluginTag' is non-NULL in this function, before the code you're adding. I don't know if that is by design or not, but in any case lets do one NULL check at the top of the function and then don't check it again. This will mean removing other NULL checks in the function as well, not just the one you're adding.
Comment 10 Jim Mathies [:jimm] 2010-10-15 09:00:09 PDT
Created attachment 483491 [details] [diff] [review]
updated patch
Comment 11 Jim Mathies [:jimm] 2010-10-15 09:01:54 PDT
I guess to match the formatting here I should also add parenthesis around that. I'll update that in the patch I land.
Comment 12 Jim Mathies [:jimm] 2010-10-15 09:10:54 PDT
http://hg.mozilla.org/mozilla-central/rev/6bef1538745f

Note You need to log in before you can comment on or make changes to this bug.