Reply header uses current date/time rather than the date/time of the original message

RESOLVED WORKSFORME

Status

Thunderbird
Preferences
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Kyle K., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.4) Gecko/20100624 Red Hat/3.6-8.el5 (CK-DWA) (CK-DWA) Firefox/3.6.4
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.9) Gecko/20100921 Fedora/3.1.4-1.fc13 Thunderbird/3.1.4

When I reply to an email message, the reply header Thunderbird places above the quoted text includes the date & time relative to the time I pressed the "Reply" button instead of being the date & time of the originating message.

Reproducible: Always

Steps to Reproduce:
1. Reply to an old email
Actual Results:  
The reply header includes the current date / time value
(i.e. On 2010-10-11 14:58:04 -0700, John Smith wrote:)


Expected Results:  
The reply header should include the original message's date / time value
(i.e. On 2010-10-08 16:31:33 -0700, John Smith wrote:)

(all mailnews.reply_header_* options at default values):

mailnews.reply_header_authorwrote     = %s wrote
mailnews.reply_header_colon           = :
mailnews.reply_header_locale          =
mailnews.reply_header_ondate          = On %s
mailnews.reply_header_originalmessage = -------- Original Message --------
mailnews.reply_header_separator       = ,
mailnews.reply_header_type            = 2
(Reporter)

Updated

7 years ago
Version: unspecified → 3.1
Severity: major → normal
OS: Linux → All

Comment 1

7 years ago
Can't reproduce that with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101013 Thunderbird/3.3a1pre
Always original message date inserted.
(Reporter)

Comment 2

7 years ago
So is this a Linux only bug? Or should I try a more recent build? The version I'm using is the latest available in Fedora 13.

Comment 3

7 years ago
I suggest you to try latest trunk build to see if it works for you I highly doubt this is OS depend.
(Reporter)

Comment 4

7 years ago
I can confirm that this is fixed in Mozilla/5.0 (X11; Linux x86_64; rv:2.0b13pre) Gecko/20110318 Thunderbird/3.3a4pre.

It's still a bug in Thunderbird/3.1.9, however, which is the default for Fedora 14 right now.
(In reply to comment #4)
> I can confirm that this is fixed in Mozilla/5.0 (X11; Linux x86_64;
> rv:2.0b13pre) Gecko/20110318 Thunderbird/3.3a4pre.
> 
> It's still a bug in Thunderbird/3.1.9, however, which is the default for Fedora
> 14 right now.

cool.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 6

7 years ago
Hm, I don't see that in Ubuntu 10.10 for example.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.14) Gecko/20110223 Thunderbird/3.1.8
(Reporter)

Comment 7

7 years ago
Must just be a 3.1.9 bug then.
(In reply to comment #7)
> Must just be a 3.1.9 bug then.

If you're saying it regressed between 3.1.8 and 3.1.9 that is highly unlikely as no code relating to date items or emails changed between those two releases.
(Reporter)

Comment 9

7 years ago
Hmmm. Very strange since I just realized I originally logged this bug for version 3.1.4 from Fedora 13. Could this somehow be a Fedora build problem?
You need to log in before you can comment on or make changes to this bug.