Closed Bug 603476 Opened 14 years ago Closed 12 years ago

Code rather than intended depiction is shown for MHTML message

Categories

(Firefox :: General, defect)

3.6 Branch
x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 18764

People

(Reporter: Panchito42, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

Instead of the intended file, what I get when hitting the "October 2010" tab at the URL entered above, is the code, part of which I show below:

From: "Saved by Windows Internet Explorer 8"
Subject: The Conservative Forum of Silicon Valley Newsletter
Date: Tue, 5 Oct 2010 23:12:00 -0700
MIME-Version: 1.0
Content-Type: multipart/related;
	type="text/html";
	boundary="----=_NextPart_000_0000_01CB64E2.B73A2A20"
X-MimeOLE: Produced By Microsoft MimeOLE V6.1.7600.16543

This is a multi-part message in MIME format.

------=_NextPart_000_0000_01CB64E2.B73A2A20
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
Content-Location: http://campaign.r20.constantcontact.com/render?llr=f57adubab&v=001TEa7HUw8hRGSRFLXd61pNid-lpJWQnviy-Gopl53mIEUvaaYpD2r9J5XGrTQe69_GyzyH4JESaUu6YPRo8UHprSqUJNBpi5EsA-eCnMwxHAf2W_k-dtEvrJjYiudR4tkA3NZ6aFVIAneVIH_L9bQvT8KRzNbzpu8xWfFYVPwdcQih88kSwv06_UdS-EMkSz1KWPFzJqM6LBu7jq9R0jc0GMCfVuVpM8dYjutTDI1vFIfK-eF3lcqDtG2uOSyHRI2u-ayQ6cPOhJAqq73Si2YhzFdz6GhLd0Bh_LorinLsTeUciXbqjphD7KgG6GEPBHI4OALc3SCA0AwTaMeV4Mm3zBdWQYEF5uQ

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD><TITLE>The Conservative Forum of Silicon Valley =
Newsletter</TITLE>
<META content=3D"text/html; charset=3Diso-8859-1" =
http-equiv=3DContent-Type>
<STYLE type=3Dtext/css>#VWPLINK {
	DISPLAY: none
}
</STYLE>

<META name=3DGENERATOR content=3D"MSHTML 8.00.7600.16625"></HEAD>
<BODY leftMargin=3D0 rightMargin=3D0 topMargin=3D0><!--Copyright (c) =
1996-2010 Constant Contact. All rights reserved.  Except as permitted =
under a separate=0A=
written agreement with Constant Contact, neither the Constant Contact =
software, nor any content that appears on any Constant Contact site,=0A=
including but not limited to, web pages, newsletters, or templates may =
be reproduced, republished, repurposed, or distributed without the=0A=
prior written permission of Constant Contact.  For inquiries regarding =
reproduction or distribution of any Constant Contact material, please=0A=
contact legal@constantcontact.com.-->
<DIV style=3D"PADDING-BOTTOM: 10px; BACKGROUND-COLOR: #ffffff" =
align=3Dcenter>
<DIV=20
style=3D"WIDTH: 600px; FONT-FAMILY: verdana,arial; COLOR: #000000; =
FONT-SIZE: 8pt"=20
align=3Dleft><FONT=20
style=3D"FONT-FAMILY: verdana,arial; COLOR: #000000; FONT-SIZE: 8pt" =
color=3D#000000=20
size=3D1 face=3Dverdana,arial>
<CENTER>
<TABLE id=3DVWPLINK width=3D595 bgColor=3D#ffffff>


Reproducible: Always

Steps to Reproduce:
1.Go to http://www.theconservativeforum.com/
2.Click on the NEWSLETTERS tab, on the left pane
3.Click on October 2010 tab, and presto! a deluge of code bursts on the screen  
Actual Results:  
shown already on the Details section above

Expected Results:  
An splendorous effluence of the October Newsletter of the Conservative Forum of Silicon Valley, where grassroots conservative, America-loving patriots gather for lawful, peaceful and civil activism, among other great activities, such a lectures, networking, socializing, canvassing, voter registration, suffrage integrity preservation, and so forth

Showing the beautifully html formatted October Newsletter.

I do love Mozilla, and hope that you solve that glitch. I do develop real time embedded software and mostly stuff related to firmware, ROM-BIOs, kernels and all those ugly things I love; tell me what kind of stuff should I get into to help you folks with volunteer work on Mozilla Firefox (pearl? Java? html?) tell me, please.
You can call me at 408-348-8345 for more explanations if you so desire.
That's not a correctly formatted HTML message, that's a MHTML message, which includes the images too. Firefox doesn't support that - it's Internet Explorer specific. and it's used to save an entire webpage in a single file (images included).

Note that it's also served with the text/plain MIME-type (probably because of the .mht extension), although Firefox expects a text/html one. Even if Firefox would recognize the content, it would still be forced to display it as plain text (with the codes and all).
Version: unspecified → 3.6 Branch
Boils down to being a duplicate of bug 18764
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Summary: Code rather than intended depiction is shown → Code rather than intended depiction is shown for MHTML message
You need to log in before you can comment on or make changes to this bug.