Crash [@ ClearAllTextRunReferences]

RESOLVED FIXED

Status

()

Core
Layout: Text
--
critical
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Jesse Ruderman, Assigned: mats)

Tracking

(Blocks: 1 bug, 4 keywords)

Trunk
x86
Mac OS X
assertion, crash, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking1.9.2 .13+, status1.9.2 .13-fixed, blocking1.9.1 .16+, status1.9.1 .16-fixed)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 482386 [details]
testcase (may leak/crash?)

###!!! ASSERTION: Unexpected start frame in simple flow text run: 'f != oldTextRun->GetUserData()', file layout/generic/nsTextFrameThebes.cpp, line 1981

Crash during shutdown [@ ClearAllTextRunReferences]
(Reporter)

Comment 1

7 years ago
Created attachment 482387 [details]
stack traces
Assignee: nobody → matspal
(Reporter)

Comment 2

7 years ago
Bug 603510 has a saner testcase (no Editor) and triggers a related assertion.
(Assignee)

Comment 3

7 years ago
Fixed by backing out:
http://hg.mozilla.org/mozilla-central/rev/9af1a5813a7b
Blocks: 571995
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

7 years ago
Crashtest: http://hg.mozilla.org/mozilla-central/rev/783057552c51
Marking this regression a branch blocker for qa verification because bug 571995 is a blocker.
blocking1.9.1: --- → .16+
blocking1.9.2: --- → .13+
status1.9.1: --- → wanted
status1.9.2: --- → wanted
(Assignee)

Comment 6

7 years ago
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/650e7b0d6d34
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/bd03fbc2b2fc
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/19e3f097936a
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/91bf1ee0a8ac
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/5cb35072f373
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/6444dcb39b02

http://hg.mozilla.org/releases/mozilla-1.9.2/rev/64e803656a1f
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/ee365bf30311
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/0ac503e14b53
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/1d2fa8e53cc3
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/57ce1356af46
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/3956db8d0373
status1.9.1: wanted → .16-fixed
status1.9.2: wanted → .13-fixed
Flags: in-testsuite+
Crash Signature: [@ ClearAllTextRunReferences]
You need to log in before you can comment on or make changes to this bug.