"ASSERTION: Unexpected start frame in multiflow text run"

RESOLVED FIXED

Status

()

Core
Layout: Text
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Jesse Ruderman, Assigned: mats)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking1.9.2 .13+, status1.9.2 .13-fixed, blocking1.9.1 .16+, status1.9.1 .16-fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 482408 [details]
testcase

###!!! ASSERTION: Unexpected start frame in multiflow text run: 'f != userData->mMappedFlows[i].mStartFrame', file layout/generic/nsTextFrameThebes.cpp, line 1987

See also bug 603490, which triggers a related assertion.
(Assignee)

Updated

7 years ago
Assignee: nobody → matspal
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Comment 1

7 years ago
Fixed by backing out:
http://hg.mozilla.org/mozilla-central/rev/9af1a5813a7b
Blocks: 571995
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

7 years ago
Crashtest: http://hg.mozilla.org/mozilla-central/rev/65794a178da6
Flags: in-testsuite+
Marking this regression a branch blocker for qa verification because bug 571995 is a blocker.
blocking1.9.1: --- → .16+
blocking1.9.2: --- → .13+
status1.9.1: --- → wanted
status1.9.2: --- → wanted
Keywords: regression
(Assignee)

Comment 4

7 years ago
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/650e7b0d6d34
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/bd03fbc2b2fc
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/19e3f097936a
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/91bf1ee0a8ac
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/5cb35072f373
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/6444dcb39b02

http://hg.mozilla.org/releases/mozilla-1.9.2/rev/64e803656a1f
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/ee365bf30311
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/0ac503e14b53
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/1d2fa8e53cc3
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/57ce1356af46
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/3956db8d0373
status1.9.1: wanted → .16-fixed
status1.9.2: wanted → .13-fixed
You need to log in before you can comment on or make changes to this bug.