Closed Bug 603538 Opened 10 years ago Closed 6 years ago

dropdown and radio buttons not fuctioning in iframe

Categories

(Web Compatibility :: Desktop, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: bill, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

Dropdown box and radio buttons not functioning within iframe on page.  These do work however using I.E.


Reproducible: Always

Steps to Reproduce:
1.Load the page
2.Click on drop down box for select country or radio button for business/residential
3. cannot select country or radio button.
Actual Results:  
dropdown and radio buttons are not accessible.

Expected Results:  
Dropdown box should list countries to select.  Radio buttons should allow to choose between business and residential.
I can reproduce the Issue using Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101011 Firefox/4.0b8pre (http://hg.mozilla.org/mozilla-central/rev/5a41a70eb631), but not with Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.11) Gecko/20101001 Firefox/3.6.11 (http://hg.mozilla.org/releases/mozilla-1.9.2/rev/053f07027a38).

If I load it (http://www.voip.prepaidcallscheap.com/voip2.php) directly, Dropdowns/Checkboxes work.
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk
The parent page has the id="copy" div positioned over that content, so clicks end up targeting that div.  (In my case it overlaps the <select> but not the radio buttons, but that depends on the font size you have set; I would fully expect any observed differences from 3.6 to be due to font-size differences.)

I see the same behavior in 3.6 (on Mac).

IE has some weird behavior around transparent divs and events, which is why it works there.

Fundamentally, this is a bug in the page: the div with id="first" is floated left, has a fixed height, contains the iframe, and is too short for its content, so the iframe overflows.  Then the iframe ends up under the next left float (which is the id="copy" div.
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
Product: Core → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified
This web site is bogus also on Safari and Firefox recent versions.
It proposes also to download a php file.

Though I'm not sure there is anything to fix. The Web site doesn't seem really operational. Or more exactly it seems to be an Ad honey pot.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.