No loading indicator for popup windows (or any window without tab bar)

VERIFIED FIXED in Firefox 4.0b11

Status

()

VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: tetsuharu, Unassigned)

Tracking

({regression})

Trunk
Firefox 4.0b11
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101012 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101012 Firefox/4.0b8pre

On new progress throbber (bug 602964), User does not recognize the page's loading status which is opened in popup window without tab bar.


Reproducible: Always

Steps to Reproduce:
1. Open the page on popup window without tab bar.
2. There is no way to know the page's loading status.
(Reporter)

Updated

8 years ago
Blocks: 602964
Created attachment 482537 [details]
Testcase

Add the test case.

Comment 2

8 years ago
Confirmed. The simplest solution would be to use the same throbber system on the favicon in the identity box when there is no tab bar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Summary: Do not knowing the page's loading status on popup window without tab bar. → No loading indicator for popup windows (or any window without tab bar)
Version: unspecified → Trunk

Comment 3

8 years ago
Please note that popup icon has favicon in the window title bar, but for normal window with only 1 tab opened and "Always show tab bar" option switched off is it in URL bar

Comment 4

8 years ago
http://www.stephenhorlander.com/pages/activity-circles/activityCircles-test.html

They also look like sperm swimming up hill. Is this what you want to represent Firefox?? The Progress Lines were far superior.
You are getting the activity indicator shown with the URL bar though.

Comment 6

8 years ago
(In reply to comment #5)
> You are getting the activity indicator shown with the URL bar though.

Yes, that's right. But the throbber should be a replacement for the progress line and this was shown in the described case.

Comment 7

8 years ago
I'd like to point out that sometimes the popup window doesn't have any url bar either

Comment 8

8 years ago
Can we not add the throbber over the favicon in the URL bar. We know we have it in the palette, so it shouldn't be too hard.

Comment 9

8 years ago
Another idea is to simply have a tab. After all, we can draw into the title bar.

Comment 10

8 years ago
(In reply to comment #9)
> After all, we can draw into the title bar.

Not on all OSes.

Comment 11

8 years ago
(In reply to comment #10)
> (In reply to comment #9)
> > After all, we can draw into the title bar.
> 
> Not on all OSes.

Well, on said OSes, maybe we should just display a tab bar? Or perhaps we could do what Opera do and display the tab in the main window?
> Well, on said OSes, maybe we should just display a tab bar? Or perhaps we could
> do what Opera do and display the tab in the main window?

that behavior, besides being strange and unexpected, confuses the user, who expects the OS to manage open windows, not the browser
Lets move forward by getting some UX feedback.
blocking2.0: --- → ?
Keywords: uiwanted
(Reporter)

Updated

8 years ago
Severity: normal → blocker
Not going to block on this if it's not a regression.
blocking2.0: ? → -

Comment 15

8 years ago
It's a regression from the change to a throbber from a progress line.
Duplicate of this bug: 620107

Comment 17

8 years ago
Has there been any UX feedback on this?
I don't see what this has to do with bug 602964.
Blocks: 574688, 481359
No longer blocks: 602964
Depends on: 482985
Keywords: regression

Updated

8 years ago
Severity: blocker → normal
(In reply to comment #10)

how it was in 3.6?
the progress-meter in the status bar, right?
you have to admit, that you 100% **** up with all this statusbar removal.
This idea to remove it was really stupid. All you needed to do is just make the items inside of it be configurable, but no, you need to **** ruin everything, remove the **** link alert from it (though the majority was against), then cutting the damn progressmeter... why? what was the profit of these actions?
what is the real difference between old statusbar and new addon-bar besides that the items inside of it are now configurable and that it has a **** ugly close button, that **** up the whole design thing: do any other toolbars (except the findbar which was meant to be temporarily opened) have the **** close button? do they?
your director should be fired.
>Has there been any UX feedback on this?

place the throbber (connecting/loading) on the far left side of the location bar.

>do any other toolbars
>(except the findbar which was meant to be temporarily opened) have the fucking
>close button? do they?

extension toolbars will likely have this control added in Firefox 5
(In reply to comment #20)
> >Has there been any UX feedback on this?
> 
> place the throbber (connecting/loading) on the far left side of the location
> bar.

Faaborg probably meant to type "title bar", since there is no location bar in the popup window in the test case.
Keywords: uiwanted
Popups have a location bar to prevent spoofing, unless you toggle dom.disable_window_open_feature.location.
Weird, can't remember ever touching that, but it was set on my instance. Thanks.
(In reply to comment #20)
> extension toolbars will likely have this control added in Firefox 5
extension toolbars? there are more than one planned? the current extension toolbar already has that stupid useless button. But this is a really dumb decision - why not add a close button for tabbar then? and for the location bar. and for the menu-bar. and for the bookmarks-toolbar... why not?

Comment 25

8 years ago
(In reply to comment #24)
> (In reply to comment #20)
> > extension toolbars will likely have this control added in Firefox 5
> extension toolbars? there are more than one planned? the current extension
> toolbar already has that stupid useless button. But this is a really dumb
> decision - why not add a close button for tabbar then? and for the location
> bar. and for the menu-bar. and for the bookmarks-toolbar... why not?

I believe he's referring to bars like the Google Toolbar, Yahoo Toolbar, etc. Either way, this isn't the place for that conversation.
Created attachment 500259 [details]
Screenshot of test case on windows

>Faaborg probably meant to type "title bar", since there is no location bar in
>the popup window in the test case.

since we have the location bar, we might as well place it there.  It is somewhat useful information to have the application icon placed on pop-up windows.
>I believe he's referring to bars like the Google Toolbar, Yahoo Toolbar, etc.
>Either way, this isn't the place for that conversation

I was, and we'll have that conversation in a more public location after Firefox 4. Overall problem is that users who are interested in having more space for the content area may be more likely to switch browsers than to learn about, locate, and then use the add-ons manager in Firefox.
(In reply to comment #14)
> Not going to block on this if it's not a regression.

Why is this still blocking2.0-? This is clearly a regression from Fx3.6 but I don't see the reason of keeping - from above comments. On Fx3.6, we can know the progress by the statusbar. Now, the statusbar has gone and new progressbar below the locationbar has been canceled. Therefore, I'm requesting for blocking2.0 again.

This bug is very inconvenient when I try to login some websites which load their login page on popup window. Especially, when I forget their ID and password, i.e., when I need to try to login two or more times, this bug is very annoying for me.
blocking2.0: - → ?
I'm sorry that it annoys you, but I agree with Dietrich's assertion - the throbber didn't work in 3.6, and therefore this isn't a regression and not a blocker. We decided to remove the statusbar by design.
blocking2.0: ? → -
(In reply to comment #31)
> I'm sorry that it annoys you, but I agree with Dietrich's assertion - the
> throbber didn't work in 3.6, and therefore this isn't a regression and not a
> blocker.

The regression is that there was feedback on progress and now there isn't.

> We decided to remove the statusbar by design.

This bug isn't asking for any specific solution like bringing the status bar back.

Comment 33

8 years ago
(In reply to comment #31)
> I'm sorry that it annoys you, but I agree with Dietrich's assertion - the
> throbber didn't work in 3.6, and therefore this isn't a regression and not a
> blocker.

If you only look at the throbber, you are right. If you look at the whole feedback of the browser, you are not, because the feedback in the statusbar is missing now. So from a user perspective this is a clear regression.

This problem not only occurs with popup windows, but also if you have unchecked the option "always show the tab bar" in the preferences. If you have got only one tab and unchecked this option, you have got the same problem. 

And no, I don't want the statusbar back. My preferred solution would be replacing the locationbar icon by the throbber when the page is loading.

Comment 34

8 years ago
(In reply to comment #32)
> (In reply to comment #31)
> > I'm sorry that it annoys you, but I agree with Dietrich's assertion - the
> > throbber didn't work in 3.6, and therefore this isn't a regression and not a
> > blocker.
> 
> The regression is that there was feedback on progress and now there isn't.
> 
> > We decided to remove the statusbar by design.
> 
> This bug isn't asking for any specific solution like bringing the status bar
> back.

I'm with Dao on this. This is blatantly a regression. You can't lose functionality completely in favour of something else and then not put in measures to maintain the functionality said functionality across the board. I myself am in favour of the bulk of current UI changes. But pleading ignorance in the face of people who desire to know whether a popup is doing something or not isn't on. At the very least this is a softblocker.
(In reply to comment #32)
> (In reply to comment #31)
> > I'm sorry that it annoys you, but I agree with Dietrich's assertion - the
> > throbber didn't work in 3.6, and therefore this isn't a regression and not a
> > blocker.
> 
> The regression is that there was feedback on progress and now there isn't.
> 
> > We decided to remove the statusbar by design.
> 
> This bug isn't asking for any specific solution like bringing the status bar
> back.

Dão's thought is same as mine completely.

(In reply to comment #33)
> And no, I don't want the statusbar back. My preferred solution would be
> replacing the locationbar icon by the throbber when the page is loading.

Sounds reasonable for me. Seems this isn't risky change, but improves UX well.
I think bug 628654 addressed this.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Depends on: 628654
No longer depends on: 482985
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b11
Thanks.

-> v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.