Extensions can't be downloaded with IPv6 from releases.mozilla.org

RESOLVED WORKSFORME

Status

mozilla.org Graveyard
Server Operations
--
major
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: Jens-Erik Weber, Assigned: justdave)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; de-DE; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; de-DE; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

releases.mozilla.org has an AAAA/IPv6 entry, try “host releases.mozilla.org”.
I use a IPv6 tunnel with Miredo (Teredo for Mac) and can reach other IPv6 sites without any problem, but not releases.mozilla.org, the server where extensions are downloaded. I can't open it from a browser window in Firefox or other browsers like Safari, and also “ping6 releases.mozilla.org” yields a 100 % package loss.

So if threre's no Miredo/Teredo specific problem, releases.mozilla.org claims to be reachable with IPv6, but in fact isn't. I'm not the only one having this problem, see <http://support.mozilla.com/tiki-view_forum_thread.php?comments_offset=0&comments_threadId=0&comments_parentId=341534&comments_threshold=0&thread_sort_mode=commentDate_asc&forumId=1&time_control=86400>. But of course switching off IPv&, the future of the Internet, can't be a solution, only a temporary workaround!

So please either remove the AAAA/IPv6 entry as long as releases.mozilla.org has an AAAA/IPv6 entry, try “host releases.mozilla.org”.
I use a IPv6 tunnel with Miredo (Teredo for Mac) and can reach other IPv6 sites without any problem, but not releases.mozilla.org, the server where extensions are downloaded. I can't open it from a browser window in Firefox or other browsers like Safari, and also “ping6 releases.mozilla.org” yields a 100 % package loss.

So if threre's no Miredo/Teredo specific problem, releases.mozilla.org claims to be reachable with IPv6, but in fact isn't. I'm not the only one having this problem, see <http://support.mozilla.com/tiki-view_forum_thread.php?comments_offset=0&comments_threadId=0&comments_parentId=341534&comments_threshold=0&thread_sort_mode=commentDate_asc&forumId=1&time_control=86400>. But of course switching off IPv&, the future of the Internet, can't be a solution, only a temporary workaround!

So please either remove the AAAA/IPv6 entry as long as releases.mozilla.org is not reachable via IPv6 or connect this site to IPv6!

Reproducible: Always

Steps to Reproduce:
1. Connect your computer to IPv6 e. g. with Miredo/Teredo
2. Try to update or install extensions
3. Wait for the error message
Actual Results:  
time out

Expected Results:  
download via IPv6

IPv6 access via Miredo/Teredo in my case

Updated

8 years ago
Assignee: nobody → server-ops
Component: Public Pages → Server Operations
Product: addons.mozilla.org → mozilla.org
QA Contact: web-ui → mrz
Version: unspecified → other

Updated

8 years ago
Assignee: server-ops → justdave
releases.geo.mozilla.com has IPv6 address 2001:6b0:e:2018::1337

That's umu.se.  Bringing in that sysadmin.
It's night time in Sweden right now... if you're not afraid to mess with your hosts file, can you try these IP addresses and see if they work?

2001:4f8:0:2::1f
2610:148:fd80:3d6f:209:3dff:fe12:7bf9

Those are the other two ipv6 hosts that we have available to the load balancer (but they're disabled at the moment).  If either of those works, I can put that one back in and pull out the umu.se one until maswan gets it fixed.
(Reporter)

Comment 3

8 years ago
It's night time here in Germany, too... I'm not afraid messing with my /etc/hosts, but since entering an IPv4 address for releases.geo.mozilla.com yesterday didn't help, I rather check with ping6 and with entering the IP address in browsers.

ping6 2001:4f8:0:2::1f works perfectly, http://[2001:4f8:0:2::1f]/pub/mozilla.org/addons/ gives a “404 - Not Found”, i. e. the http server works, but the add-ons are not available on this server. host 2001:4f8:0:2::1f
f.1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.2.0.0.0.0.0.0.0.8.f.4.0.1.0.0.2.ip6.arpa domain name pointer mozilla.isc.org.

ping6 2610:148:fd80:3d6f:209:3dff:fe12:7bf9 doesn't work: 100 % packet loss. http://[2610:148:fd80:3d6f:209:3dff:fe12:7bf9]/pub/mozilla.org/addons/ -> time out, host 2610:148:fd80:3d6f:209:3dff:fe12:7bf9
Host 9.f.b.7.2.1.e.f.f.f.d.3.9.0.2.0.f.6.d.3.0.8.d.f.8.4.1.0.0.1.6.2.ip6.arpa not found: 3(NXDOMAIN) Nothing works for the second address.

Comment 4

8 years ago
As far as I can tell things work fine here. 2001:6b0:e:2018::1337 is responding and I have global connectivity (ping6 2001:4f8:0:2::1f works perfectly from here too, along with other ipv6 hosts).

Can you supply your ipv6 address and I can check if there is any connectivity problem to your network in particular?
(Reporter)

Comment 5

8 years ago
My current ipv6 address is 2001:0:53aa:64c:0:5207:a633:75dd. It's an address I got via Teredo tunneling service, so I guess it's not permanent, and besides it's a notebook which is not always on. I'm connected through a UMTS/3G surf stick with mobile phone network. I'm not sure if my Mac is reachable for incoming connections through ipv6 tunneling through a ipv4 NAT.

I've tested several other ipv6 sites which all work for me except for www.ipv6.org, and - mystery - it's also a site in Sweden...
www.ipv6.org is an alias for shake.stacken.kth.se

Comment 6

8 years ago
How about www.nordu.net / 2001:948:4:2::19?

From here the path to your IP stops at:
10. ndn-gw.surf.net                   0.0%     6   38.9  38.9  38.9  38.9   0.0
11. AE1.500.JNR01.Asd002A.surf.net    0.0%     6   55.3  41.8  39.1  55.3   6.6
12. onweer-router.Customer.surf.net   0.0%     6   39.1  39.1  39.1  39.1   0.0
13. ???

And I can reach other v6 hosts in surf.net fine.
(Reporter)

Comment 7

8 years ago
I don't get to www.nordu.net with ipv6:

$ traceroute6 www.nordu.net
traceroute6 to server.nordu.net (2001:948:4:2::19) from 2001::53aa:64c:0:307e:a633:767b, 30 hops max, 12 byte packets
 1  * * *
 2  * 2001::53aa:64c:0:307e:a633:767b  0.815 ms !A  0.622 ms !A

With ipv4 I get this route:

$ traceroute www.nordu.net
traceroute to server.nordu.net (193.10.252.19), 64 hops max, 40 byte packets
 1  * * *
 2  10.80.4.35 (10.80.4.35)  275.215 ms  259.929 ms  248.760 ms
 3  89.204.136.17 (89.204.136.17)  228.352 ms  371.817 ms  325.131 ms
 4  89.204.136.2 (89.204.136.2)  216.794 ms  409.095 ms  254.609 ms
 5  xmwc-brln-de01-gigaet-1-4-550.nw.mediaways.net (195.71.234.225)  222.570 ms  289.101 ms  248.331 ms
 6  195.66.225.24 (195.66.225.24)  248.883 ms  636.166 ms  309.968 ms
 7  dk-ore.nordu.net (109.105.97.30)  398.128 ms  437.135 ms  445.221 ms
 8  se-fre.nordu.net (109.105.97.5)  471.087 ms  397.185 ms  409.027 ms
 9  se-tug.nordu.net (109.105.97.2)  298.260 ms  365.970 ms  410.719 ms
10  server.nordu.net (193.10.252.19)  358.010 ms  332.193 ms  435.642 ms

Is it again a Swedish server? I don't know surf.net. My ipv6 address seems to change every couple of hours, so it's no surprise you don't get through to me.

My Teredo server is teredo.remlab.net. A working ipv6 route looks like this:

traceroute6 to www.heise.de (2a02:2e0:3fe:100::7) from 2001::53aa:64c:0:307e:a633:767b, 30 hops max, 12 byte packets
 1  teredo2.bit.nl  1708 ms  520.142 ms  500.419 ms
 2  teredo2-gw.jun1.fra4.network.bit.nl  948.872 ms  651.18 ms  460.12 ms
 3  te3-1.c302.f.de.plusline.net  1367.91 ms  499.382 ms  448.152 ms
 4  te2-4.c102.f.de.plusline.net  926.958 ms  483.302 ms  513.01 ms
 5  te6-2.c13.f.de.plusline.net  875.633 ms  627.298 ms  419.389 ms
 6  www.heise.de  443.464 ms  578.141 ms  609.714 ms

Do you get through to these intermediate servers?

So it seems to be a routing problem from the Teredo server to Swedish ipv6 servers. But whose fault is this?

Like I said in my original report, there are also others who couldn't reach the FF extensions server due to ipv6 connectivity problems.

Comment 8

8 years ago
No, but nordunet is the network that aggregates all the swedish, finnish, norwegian, danish and icelandic academic network.

I can get to teredo2.bit.nl fine over ipv6, but teredo.remlab.net does not have an AAAA-record I can check against. Last few hops to teredo2.bit.nl:

 9. 2001:948:1:7::2                   0.0%     2   38.7  38.7  38.7  38.7   0.0
10. 2001:7f8:1::a501:2859:2           0.0%     2   40.0  40.1  40.0  40.1   0.1
11. 2001:7b8:0:324::2                 0.0%     2   45.2  45.2  45.2  45.2   0.1
12. 2001:7b8:7:a8f:213:154:235:74     0.0%     2   49.8  49.8  49.8  49.8   0.0


And to www.heise.de:
 7  dk-ore.nordu.net (2001:948:1:2::3)  18.973 ms  18.965 ms  18.982 ms
 8  uk-hex.nordu.net (2001:948:1:8::2)  39.924 ms  39.945 ms  39.971 ms
 9  linx-1.init7.net (2001:7f8:4::32e6:1)  44.032 ms  40.081 ms  40.099 ms
10  r1ams1.core.init7.net (2001:1620:2::69)  42.996 ms  43.120 ms  43.043 ms
11  r1fra1.core.init7.net (2001:1620:2::65)  49.548 ms  49.598 ms  49.630 ms
12  te3-1.c101.f.de.plusline.net (2001:7f8::3012:0:1)  45.454 ms  45.538 ms  45.528 ms
13  te6-1.c13.f.de.plusline.net (2a02:2e0:1::1e)  46.228 ms  45.551 ms  45.516 ms
14  www.heise.de (2a02:2e0:3fe:100::7)  45.544 ms  45.222 ms  45.077 ms

I think your teredo server is having routing problems, but since I don't have the IPv6 number of that, I can't really tell for sure.
I'm resolving this mostly to get it out of my queue because from the conversation so far it appears that the issue is something outside of Mozilla's control.  Feel free to continue discussing here if it'll help debug, and if it does turn out to be something we can do anything about on our end, feel free to reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.