Closed Bug 603619 Opened 9 years ago Closed 9 years ago

fennec with app argument doesn't open the default xulrunner window specified by the toolkit.defaultChromeURI preference

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: joliclic, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.2.10) Gecko/20100915 Ubuntu/10.04 (lucid) Firefox/3.6.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:2.0b7pre) Gecko/20101006 Firefox/4.0b7pre Fennec/4.0b1

With Fennec 4.0b1, launching a XULRunner application with fennec and the -app argument failed.
This is the fennec window which are open, instead of those specified by the toolkit.defaultChromeURI preference.


The XULRunner application is well registred, I can see it with nsIXULAppInfo.
I suppose that this bug exists since the resolution of bug 593782.

A solution can be to register the component browserCLH.js only for Fennec in the MobileComponents.manifest.
A side effect is that the 'chrome' argument will perhaps fail for XULRunner application launch via Fennec. But they can add theirs own command line handlers.
A patch with this solution in the next comment.

Reproducible: Always

Steps to Reproduce:
1.download the 'Hello World' XUlRunner application from https://developer.mozilla.org/en/Getting_started_with_XULRunner

2.try to launch it with :
pathToFennec/fennec -app pathToMyApp/myapp/application.ini
3.
Actual Results:  
The Fennec main window is opened

Expected Results:  
The Hello World window should open

A more advanced test can be performed:
Download the DOM Inspector extension, and unpack it into the extensions folder of the MyApp application, i.e. into pathToMyApp/extensions/ , then launch the application with:
pathToFennec/fennec -app pathToMyApp/myapp/application.ini -jsconsole -inspector

Then in the DOM Inspector you can see that the registred application is really myapp.
Comment on attachment 482541 [details] [diff] [review]
register the browserCLH.js component only for Fennec

Requesting review to Fabrice since he is working on the Web Applications support and this could potentially affect his work
Attachment #482541 - Flags: review?(fabrice.desre)
Comment on attachment 482541 [details] [diff] [review]
register the browserCLH.js component only for Fennec

Looks OK to me. Shouldn't affect any current WebApps work - as those apps are all run using Fennec as the app.

Fabrice can review too.
Attachment #482541 - Flags: review+
Attachment #482541 - Flags: review?(fabrice.desre) → review+
http://hg.mozilla.org/mobile-browser/rev/275fc6efea87

Thanks for the patch joliclic!
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.