slow Rendering/Scrolling with Background Image using -moz-linear-gradient and background-size:1px ...;

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
major
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: dbmontes, Unassigned)

Tracking

({perf, testcase})

Trunk
x86_64
Windows 7
perf, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101012 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101012 Firefox/4.0b8pre

The error only appears with a background as the page, if he does variation some leave slow rendering. The problem is both windows and linux.

(traduction by google traductor, sorry for my English)

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.setingo.com/demo_problem.html
2.Wait
3.Scroll and be happy my friend
Actual Results:  
The background render slooooowwww...

Expected Results:  
render more fast

This background css is from http://www.omgubuntu.co.uk
The problem is in windows 7 x64 and ubuntu 10.10 x64.
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Summary: SLOW (≈10 seconds) rendering of background without images → slow Rendering/Scrolling with Background Image using -moz-linear-gradient
Created attachment 482571 [details]
Reporter's Testcase

Confirmed on WinXP with Build built from http://hg.mozilla.org/mozilla-central/rev/2593c8c8af8b.
Keywords: testcase

Comment 2

8 years ago
> Created attachment 482571 [details]

This code is... stupid:
 background-size: 1px 199px;
repeats a 1px wide background.

 background-size: 100% 199px;   is much faster.

Comment 3

8 years ago
Created attachment 482965 [details]
testcase with  "background-size: 100% 199px;"
(Reporter)

Comment 4

8 years ago
is true... the css is stupid. 
well, its not a bug, is a bad design of www.omgubuntu.co.uk.
sorry for the unnecessary notification.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Comment 5

8 years ago
We are not committed to handle stupid code badly.
People with more knowledge should decide about this.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
Summary: slow Rendering/Scrolling with Background Image using -moz-linear-gradient → slow Rendering/Scrolling with Background Image using -moz-linear-gradient and background-size:1px ...;

Updated

8 years ago
Status: REOPENED → UNCONFIRMED
Ever confirmed: false
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: perf
It's pretty fast on Mac actually. I wonder why.

It would be pretty easy to make this faster. We probably should, but we won't do it for Firefox 4 probably.

In the meantime, please do send feedback to the size recommending 100% instead.
This is WFM using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120617030532 with HWA on.

Explicitly turning off Azure exhibits the originally reported Issue. Thus I think this has been fixed since Azure Landing.

Comment 8

6 years ago
Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/16.0 Firefox/16.0a1

Not fixed, the second testcase has significant better scrolling performance on my system.

Comment 9

5 years ago
both the attached testcases scroll fully smooth for me on the latest Nightly 21.

Comment 10

5 years ago
confirming comment 9 with Nightly 21 from 2013-01-21
-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 8 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.