Java applet causes mouse pointer to flicker

VERIFIED WONTFIX

Status

P3
normal
VERIFIED WONTFIX
18 years ago
8 years ago

People

(Reporter: cgohier, Assigned: xiaobin.lu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
build ID 2000111604

On Windows 2000 with Pointer Shadow enabled, the Shock the Monkey ad on
Mozillazine makes the pointer flicker.

Comment 1

18 years ago
reporter: whose java runtime environment are you using?

iirc, Sun's JRE doesn't like cursor shadows. You might visit bugparade @ 
sun.com to read about it

Comment 2

18 years ago
over to OJI
Assignee: asa → edburns
Component: Browser-General → OJI
QA Contact: doronr → shrir
(Reporter)

Comment 3

18 years ago
I had the sun JRE installed. I uninstalled it and tried with the IBM JRE.

I still does the same thing.

Comment 4

18 years ago
Worksforme
Platform: PC
OS: Windows 98
Mozilla Build: 2000121804 M18 Trunk Build.

Comment 5

18 years ago
wfm too.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

18 years ago
Did you try it in Windows 2000 with the pointer shadow enabled? It's a new
setting in win2k that was not in win98.

Comment 7

18 years ago
u guessed it, will try it on win2k and comment.

Comment 8

18 years ago
reopening, using the 2000122904 nightly build on win2k with the pointer shadow 
enabled, the mouse does flicker about every second.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 9

18 years ago
& confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

18 years ago
Assignee: edburns → xiaobin.lu

Comment 10

18 years ago
Xiaobin, you have Win2000, right?  Can you accept this and investigate it?

Thanks,

Ed
(Assignee)

Comment 11

18 years ago
   Is there any update on this webpage because I can not see any applets in the 
www.mozillazine.org?
   Please let me know if I am wrong.
Status: NEW → ASSIGNED
(Assignee)

Comment 12

18 years ago
 Hi, Claude:
    Would you like to confirm that the website doesn't have an applet now for 
me?
    If there is no applet in this webpage now, I would like to close this bug.
    Thanks very much!
Xiaobin Lu
(Reporter)

Comment 13

18 years ago
Any applet with animation will make the pointer flicker.
You can see some http://javaboutique.internet.com, 

for instance the applet on
http://javaboutique.internet.com/StarWarsScroller/
makes the pointer flicker very noticably...

(Assignee)

Comment 14

18 years ago
& Confirming
(Assignee)

Comment 15

18 years ago
   Although I can see mouse flicking every seconds in 
http://javaboutique.internet.com/StarWarsScroller, I can also see the mouse 
flicking frequently in 
http://www.apple.com/trailers/dreamworks/what_lies_beneath.html. That indicates 
it is not only occurs for java, but also for other animated things like movie. 
I would like to say it is a browser general bug rather a java plugin bug. 
Ususally, the UI should not update the cursor when something changes in the 
browser.
(Assignee)

Comment 16

18 years ago
   To my suppurise,when I use to visit 
http://www.apple.com/trailers/dreamworks/what_lies_beneath.html. The mouse 
flickers every seconds. 
   This is what I thought:
   Cursor does not flick for java animated applet in IE because IE has a built 
JVM and the same thing for Netscape 4.6. Netscape 6 pulls out JVM out of the 
browser and make it as a seperate thread to run. So browser needs to talk with 
OJI and OJI talks to plugin and this causes a lot of delay which may cause the 
cursor flick. I would like explain the phenomena of above with the same reson. 
Because IE needs to talk with quicktime plugin and then quicktime player plays 
the movie as a seperate thread which may cause the cursor flick.
  How do you think?
    
(Assignee)

Comment 17

18 years ago
To my suppurise,when I use IE to visit 
http://www.apple.com/trailers/dreamworks/what_lies_beneath.html. The mouse 
flickers every seconds. 
   This is what I thought:
   Cursor does not flick for java animated applet in IE because IE has a built 
JVM and the same thing for Netscape 4.6. Netscape 6 pulls out JVM out of the 
browser and make it as a seperate thread to run. So browser needs to talk with 
OJI and OJI talks to plugin and this causes a lot of delay which may cause the 
cursor flick. I would like explain the phenomena of above with the same reason. 
Because IE needs to talk with quicktime plugin and then quicktime player plays 
the movie as a seperate thread which may cause the cursor flick.
  How do you think?
(Assignee)

Comment 18

18 years ago
Hi, Claude: 
   Please let me know how do you think about this? If you agree with me, I 
would like to close this bug.
   Thanks in advance!
Xiaobin
(Assignee)

Comment 19

18 years ago
 Since I haven't received response from bug reporter. I would like to close 
this bug. Thanks for bring this issue up!
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WONTFIX

Comment 20

18 years ago
Verified wontfix.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.