If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

find in page freezes the browser regularly

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

({hang, perf, qawanted})

Trunk
x86
Linux
hang, perf, qawanted
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(Whiteboard: WFM? [bugday-2011-05-27])

(Reporter)

Description

7 years ago
sometime in the last few weeks, this has started:

1. ctrl+F
2. start typing

Expected: type as many characters as i want, textfield fills with them

Actual: after the 3rd (usually, sometimes up to the 5th), the textfield stops showing the characters i'm typing, and the browser is hung for a second or two.

after that initial hang, everything is fine.

maybe spellcheck? maybe autocomplete?
(Reporter)

Comment 1

7 years ago
Requesting blocking due to hang. If we get confirmation from others, block it should.
blocking2.0: --- → ?
Keywords: hang, perf
Can you shark/profile this? I can't reproduce it in a quick test here. Speculatively blocking since hanging in FAYT is a significant regression. Need some reliable STR though, so flagging qawanted and regressionwindow-wanted
blocking2.0: ? → betaN+
Keywords: qawanted, regressionwindow-wanted
(Reporter)

Comment 3

7 years ago
Predictably, now that I have reported the bug, I am not able to reproduce it.

Comment 4

7 years ago
I'm able to reproduce it everytime. Ctrl-F, start typing and while the string matches, everything is ok. When the added character doesn't match anymore, firefox freezes and must be killed.

Comment 5

7 years ago
Regression range would be great.

I haven't seen the problem myself, and I use FAYT a lot.

Comment 6

7 years ago
(In reply to comment #5)
> Regression range would be great.
> 
> I haven't seen the problem myself, and I use FAYT a lot.

Ditto. If you can, post a url that you visited while this happened. I have not seen this and I think I find in content 3 - 4 times an hour.
This bug seemingly has not been reproduced by anybody since it was reported, is not WFM, blocks betaN, and is assigned to nobody.

I assert that one of the above needs to change.  I suggest -> WFM.
Whiteboard: WFM?
(Reporter)

Comment 8

7 years ago
I still see it sometimes, I just keep forgetting to make a note of the URL when it happens. It could be an add-on I have is causing it, if nobody else is seeing it :P

Also, in reply to comment #2: I can't profile it since it is not reproducible on-demand, and only lasts a couple of seconds.
(In reply to comment #8)
> I still see it sometimes, I just keep forgetting to make a note of the URL when
> it happens. It could be an add-on I have is causing it, if nobody else is
> seeing it :P

Can you try running Firefox with all extensions disabled  so that we can determine whether this is true or not?
Notes from the Grand Retriage: without STR, can't take it as a blocker.
blocking2.0: betaN+ → -

Comment 11

6 years ago
Works For Me on:
Mozilla/5.0 (X11; Linux i686; rv:6.0a2) Gecko/20110526 Firefox/6.0a2

*Note: I cannot see the issue on the latest Aurora. Nominating this bug for Resolved if the issue is not present anymore. Thanks
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: WFM? → WFM? [bugday-2011-05-27]
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.