Right Click menu disabled on interface if Flash has focus

RESOLVED DUPLICATE of bug 595132

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 595132
7 years ago
7 years ago

People

(Reporter: J.K, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

Right Click menu disabled on browser interface(tabs, bookmarks, etc) if Flash has focus.

Reproducible: Always

Steps to Reproduce:
1.Go to a site that has flash content, and click on it.
2.Without clicking on any area on that page, right click a Browser interface element, such as a tab
Actual Results:  
Nothing will happen

Expected Results:  
A context menu should appear with options relevant to the element clicked on
I tried to find a previous report of this issue but without success - confirming this report then. This is a trunk regression, Firefox 3.6.11 works fine.
Status: UNCONFIRMED → NEW
Component: Menus → XUL
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: menus → xptoolkit.widgets
Version: unspecified → Trunk
Do we know when this has been started?
blocking2.0: --- → ?
Keywords: regressionwindow-wanted
I was about to find the regression window. The bug report I got also mentions Beta 6 so it probably didn't start too long ago.
blocking2.0: ? → ---
This regressed between 2010-08-27 and 2010-08-28: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e1d55bbd1d1d&tochange=6e3f6d18c124

Not really sure which one of these checkins is responsible, could be a number of them.
Keywords: regressionwindow-wanted
Timothy, Robert, I see a number of your patches in that period which might be related, any idea?
blocking2.0: --- → ?
Probably a duplicate of bug 595132.
Yes, looks very much like it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595132
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.