If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

malformed-xml errors do not always show in the Web Console

RESOLVED DUPLICATE of bug 606498

Status

()

Firefox
Developer Tools
RESOLVED DUPLICATE of bug 606498
7 years ago
7 years ago

People

(Reporter: msucan, Assigned: msucan)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

7 years ago
The nsExpatDriver:HandleError() method logs nsIScriptError messages with the sourceName URI pointing to the malformed document. This allows us to show such errors in the Web Console, if say the user opens up a page which is a malformed XML document.

However, when the developer loads a malformed XML document with an XMLHttpRequest() we fail to show the message, since the sourceName URI doesn't point to any of the open tabs. There are other cases when this fails - eg. the use of document.load("malformed.xml")... or whatever we can think of.

We need to figure out a solution for this problem. Perhaps bug 603706 would be the answer to this bug as well?

Updated

7 years ago
Blocks: 594225

Updated

7 years ago
Assignee: nobody → mihai.sucan
(Assignee)

Comment 1

7 years ago
This is fixed by the patches from bug 606498.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 606498
You need to log in before you can comment on or make changes to this bug.