Exceptions in Web Workers fail to show in the Web Console

RESOLVED DUPLICATE of bug 606498

Status

DevTools
General
RESOLVED DUPLICATE of bug 606498
8 years ago
a month ago

People

(Reporter: msucan, Assigned: msucan)

Tracking

Trunk
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

8 years ago
Given an exception in a Web Worker, the Web Console fails to show the error.

Even if we are tracking the "DOM Worker javascript" category of nsIScriptError messages, we fail to associate the messages to any open tab. The sourceName URI points us to the source script where the error occurred, but we don't know in which tab this script is used.

We need to figure out a solution for this problem. Perhaps bug 603706 would be
the answer to this bug as well?

Updated

8 years ago
Blocks: 594225

Updated

8 years ago
Assignee: nobody → mihai.sucan
(Assignee)

Comment 1

8 years ago
This is fixed by the patches from bug 606498.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 606498

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.