Mozmill: permanent failure with a few quick-filter-bar tests

RESOLVED FIXED in Thunderbird 3.3a1

Status

Thunderbird
Testing Infrastructure
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: sid0, Assigned: sid0)

Tracking

unspecified
Thunderbird 3.3a1

Firefox Tracking Flags

(Not tracked)

Details

We've been seeing failures of the following sort on WINNT 5.2 comm-central check for the past few days.

<http://tinderbox.mozilla.org/showlog.cgi?log=Thunderbird/1286906666.1286911431.1550.gz>

TEST-UNEXPECTED-FAIL | e:\buildbot\win32-comm-central-check\build\mail\test\mozmill\quick-filter-bar\test-keyboard-interface.js | test_escape_rules
TEST-UNEXPECTED-FAIL | e:\buildbot\win32-comm-central-check\build\mail\test\mozmill\quick-filter-bar\test-toggle-bar.js | test_direct_toggle
TEST-UNEXPECTED-FAIL | e:\buildbot\win32-comm-central-check\build\mail\test\mozmill\quick-filter-bar\test-toggle-bar.js | test_control_f_triggers_display
TEST-UNEXPECTED-FAIL | e:\buildbot\win32-comm-central-check\build\mail\test\mozmill\quick-filter-bar\test-toggle-bar.js | test_constraints_disappear_when_collapsed

This is probably due to m-c, as I had to rebuild entirely to reproduce the failure.
(Assignee)

Comment 1

8 years ago
Working on the hypothesis that this is due to m-c:

<http://tinderbox.mozilla.org/showbuilds.cgi?tree=Thunderbird&maxdate=1286827045&hours=24&legend=0&norules=1> shows the point at which it started failing. The regression range is <http://hg.mozilla.org/mozilla-central/pushloghtml?tochange=05ea34e1b2a1&fromchange=19b462ec16a0>. 12bbf60c4d97 seems suspicious.
(Assignee)

Comment 2

8 years ago
Er, make that that entire push by dbaron.
(Assignee)

Comment 3

8 years ago
I've pushed a patch that causes all tests to pass locally: http://hg.mozilla.org/comm-central/rev/9bc8d9c9552e
(Assignee)

Comment 4

8 years ago
Green! And Mac is happier, too.
Assignee: nobody → sid.bugzilla
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a1
(Assignee)

Updated

8 years ago
OS: Windows 7 → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.