Personas traceback: ImportError: cannot import name resize_image

VERIFIED WORKSFORME

Status

addons.mozilla.org Graveyard
Public Pages
--
major
VERIFIED WORKSFORME
8 years ago
2 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
I can't seem to reproduce this, but hitting https://preview.addons.mozilla.org/en-US/firefox/personas/ supposedly just yielded:

Traceback (most recent call last):

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/core/handlers/base.py", line 91, in get_response
    request.path_info)

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/core/urlresolvers.py", line 214, in resolve
    for pattern in self.url_patterns:

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/core/urlresolvers.py", line 243, in _get_url_patterns
    patterns = getattr(self.urlconf_module, "urlpatterns", self.urlconf_module)

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/core/urlresolvers.py", line 238, in _get_urlconf_module
    self._urlconf_module = import_module(self.urlconf_name)

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/utils/importlib.py", line 35, in import_module
    __import__(name)

  File "/data/amo_python/www/preview/zamboni/../zamboni/urls.py", line 8, in <module>
    admin.autodiscover()

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/contrib/admin/__init__.py", line 24, in autodiscover
    import_module('%s.admin' % app)

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/utils/importlib.py", line 35, in import_module
    __import__(name)

  File "/data/amo_python/www/preview/zamboni/apps/users/admin.py", line 8, in <module>
    from .users import forms

  File "/data/amo_python/www/preview/zamboni/apps/users/forms.py", line 17, in <module>
    from . import tasks

  File "/data/amo_python/www/preview/zamboni/apps/users/tasks.py", line 10, in <module>
    from amo.utils import resize_image

ImportError: cannot import name resize_image

(Not sure if this is a spurious or one-time thing.)
If you can't reproduce it was probably an inconsistency due to code updating.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

8 years ago
Verified WFM.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.