Ricky reports filter.log is randomly strewn throughout his file system

VERIFIED DUPLICATE of bug 57806

Status

MailNews Core
Filters
P3
normal
VERIFIED DUPLICATE of bug 57806
17 years ago
9 years ago

People

(Reporter: timeless, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
1632 nsOutputFileStream * nsParseNewMailState::GetLogFile ()
1633 {
1634     // This log file is used by regular filters and JS filters
1635     if (m_logFile == nsnull)
1636     {
1637         // ### TODO file spec sub-class for log file
1638         nsFileSpec logFile("filter.log");
1639         m_logFile = new nsOutputFileStream(logFile, PR_WRONLY | 
PR_CREATE_FILE, 00600);
1640     }
1641     return m_logFile;
1642 }

I think a call to 
NS_GetSpecialDirectory(NS_APP_MAIL_50_DIR, getter_AddRefs(mailDir));
is warranted
(Assignee)

Comment 1

17 years ago
this is a dup

*** This bug has been marked as a duplicate of 57806 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Bug 57806 adds a call to NS_GetSpecialDirectory; verified dupe.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.