Last Comment Bug 603933 - outlook 2007 invitation reply wrong sender
: outlook 2007 invitation reply wrong sender
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: E-mail based Scheduling (iTIP/iMIP) (show other bugs)
: Lightning 3.3
: All All
-- normal (vote)
: 4.0.0.1
Assigned To: [:MakeMyDay]
:
:
Mentors:
: 511509 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-13 05:43 PDT by s-b-u
Modified: 2015-04-05 05:25 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
RemoveXMSOLKSENDERprop-V1.diff (1.54 KB, patch)
2015-02-01 03:59 PST, [:MakeMyDay]
philipp: review+
Details | Diff | Splinter Review

Description User image s-b-u 2010-10-13 05:43:53 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: 1.0b3pre

Notification mails are not correctly recognised by outlook 2007.
Sender of the invitation is also shown as sender of the notification (mail header).

Reproducible: Always

Steps to Reproduce:
1.send invitation from outlook 2007 to lightning
2.accept and send notification
3.back in outlook, you would see the mail is coming from your own outlook account
Comment 1 User image peter 2012-02-11 06:44:57 PST
Same behavior here with Outlook 2007 on WinXP and lightning on WinXP and Linux.
Comment 2 User image [:MakeMyDay] 2014-08-31 03:41:15 PDT
s-b-u, peter, is this still an issue with Lightning 3.3.x?
Comment 3 User image [:MakeMyDay] 2014-10-18 07:21:54 PDT
Resolving this to incomplete due to missing feedback on the above request. Please feel free to reopen the bug if you still expirience the issue.
Comment 4 User image peter 2014-10-20 00:45:12 PDT
Yes, this is still an issue.

Sorry, I didn't notice your comment.
Comment 5 User image [:MakeMyDay] 2014-10-21 15:24:41 PDT
Peter, thank you for your reply. Can you please provide what's logged to the error console (ctrl+shift+j) when reproducing the issue? Please enable debug logging for this by setting calendar.debug.log and calendar.debug.log.verbose to true using the config editor (menu->options->options->advanced->general). If these params do not already exist, just create them.
Comment 6 User image peter 2014-10-22 04:21:16 PDT
I think this is the important bit, specifically the line X-MS-OLK-SENDER;


mail text:
MIME-version: 1.0
From: peter@foo
To: organizer@foo
Date: Wed, 22 Oct 2014 11:16:47 GMT
Subject: Event Invitation Reply (Tentative): Control
Content-class: urn:content-classes:calendarmessage
Content-type: text/calendar; method=REPLY; charset=UTF-8
Content-transfer-encoding: 8BIT

BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
METHOD:REPLY
BEGIN:VEVENT
CREATED:20141022T111702Z
LAST-MODIFIED:20141022T111647Z
DTSTAMP:20141022T111647Z
UID:040000008200E00074C5B7101A82E0080000000060458877FAEDCF0100000000000000
 0010000000FD5CEAB111485B4AAF6E654CD8B69580
SUMMARY:Control
PRIORITY:5
ORGANIZER;CN=Fake Organizer:mailto:organizer@foo
ATTENDEE;CN=Jens Peter;PARTSTAT=TENTATIVE:mailto:peter@foo
DTSTART;VALUE=DATE:20150505
DTEND;VALUE=DATE:20150509
CLASS:PUBLIC
DESCRIPTION:Zeit: Dienstag\, 5. Mai 2015 00:00 bis Samstag\, 9. Mai 2015 0
 0:00 (UTC+01:00) Amsterdam\, Berlin\, Bern\, Rom\, Stockholm\, Wien.\nOrt:
  Stuttgart\n\nHinweis: Die oben angegebene Abweichung von GMT berücksicht
 igt keine Anpassungen für Sommerzeit.\n\n*~*~*~*~*~*~*~*~*~*\n\nBitte fü
 r eine eventl. Messebeteiligung den Termin frei halten.\n
LOCATION:Stuttgart
SEQUENCE:0
TRANSP:OPAQUE
X-ALT-DESC;FMTTYPE=text/html:<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//
 EN">\n<HTML>\n<HEAD>\n<META NAME="Generator" CONTENT="MS Exchange Server v
 ersion 08.00.0681.000">\n<TITLE></TITLE>\n</HEAD>\n<BODY>\n<!-- Converted 
 from text/rtf format -->\n\n<P DIR=LTR><SPAN LANG="de"><FONT FACE="Calibri
 ">Zeit: Dienstag\, 5. Mai 2015 00:00 bis Samstag\, 9. Mai 2015 00:00 (UTC+
 01:00) Amsterdam\, Berlin\, Bern\, Rom\, Stockholm\, Wien.</FONT></SPAN></
 P>\n\n<P DIR=LTR><SPAN LANG="de"><FONT FACE="Calibri">Ort: Stuttgart</FONT
 ></SPAN></P>\n\n<P DIR=LTR><SPAN LANG="de"><FONT FACE="Calibri">Hinweis: D
 ie oben angegebene Abweichung von GMT berücksichtigt keine Anpassungen f
 ür Sommerzeit.</FONT></SPAN></P>\n\n<P DIR=LTR><SPAN LANG="de"><FONT FACE
 ="Calibri">*~*~*~*~*~*~*~*~*~*</FONT></SPAN></P>\n\n<P DIR=LTR><SPAN LANG=
 "de"><FONT FACE="Calibri">Bitte für eine eventl. Messebeteiligung den Ter
 min frei halten.</FONT></SPAN></P>\n\n</BODY>\n</HTML>
X-MICROSOFT-CDO-BUSYSTATUS:TENTATIVE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-CDO-INTENDEDSTATUS:FREE
X-MICROSOFT-DISALLOW-COUNTER:FALSE
X-MS-OLK-ALLOWEXTERNCHECK:TRUE
X-MS-OLK-AUTOSTARTCHECK:FALSE
X-MS-OLK-CONFTYPE:0
X-MS-OLK-SENDER;CN=Fake Organizer:mailto:organizer@foo
END:VEVENT
END:VCALENDAR
Comment 7 User image [:MakeMyDay] 2014-10-22 14:38:49 PDT
Thanks Peter, this maybe a hint. I'll check on this.
Comment 8 User image [:MakeMyDay] 2015-02-01 03:59:55 PST
Created attachment 8557592 [details] [diff] [review]
RemoveXMSOLKSENDERprop-V1.diff

Based on [1], the X-MS-OLK-SENDER property is only intended for cases where the invitation is send by somebody else than the organizer, similar to the SENT-BY param defined in RfC 5545. This prop is only supported by Outolook 2007+ without using Exchange[2].

As we support the "sending on behalf" scenario already by using "Sent-By" in mail header and as organizer/attendees param, I think this is safe to just drop the X-MS-OLK-SENDER on sending out replies.

[1] https://msdn.microsoft.com/en-us/library/ee219350%28v=exchg.80%29.aspx#endNote256
[2] https://msdn.microsoft.com/en-us/library/ee160562%28v=exchg.80%29.aspx#id256
Comment 9 User image Philipp Kewisch [:Fallen] 2015-02-01 14:40:07 PST
Comment on attachment 8557592 [details] [diff] [review]
RemoveXMSOLKSENDERprop-V1.diff

Review of attachment 8557592 [details] [diff] [review]:
-----------------------------------------------------------------

Did you test this with Outlook clients? Code looks fine, but we should make sure it actually fixes the bug and doesn't cause any other issues.
Comment 10 User image [:MakeMyDay] 2015-02-01 22:50:51 PST
I haven't - I have no standalone Outlook around. Nevertheless, removing this is safe anyway, because not to roundtrip this property is what is intended if I got the MS reference correctly.

@Peter, s-b-u: Can you please give this patch a try?

1. Reproduce the bug with Lightning 3.3.3.
2. Make a backup of your existing calItipUtils.jsm in folder [Your TB profile folder]->extensions->{e2fda1a4-762b-4020-b5ad-a41df1933103}->modules.
3. Apply the patch attached to this bug on the file [1]
4. Again, reproduce the bug.
5. Please report back whether the sender appears now correctly in Outlook
6. Roll back the patch - at least if it didn't work.

[1] if you're not familiar with patching, just open the file with a text editor, add the lines with a leading '+' to the file - you can find the right place either by the line number by the ccontext lines above and below the new ones in the patch - and remove all the leading '+' subsequently.
Comment 11 User image peter 2015-02-02 05:00:34 PST
(In reply to MakeMyDay from comment #10)
I can confirm that the patch solves the problem.

I used Lightning 3.3.2 as participant and Outlook 2007 as initiator.

Mademyday, @MakeMyDay!
Comment 12 User image [:MakeMyDay] 2015-02-02 13:53:18 PST
Thanks for testing Peter!

https://hg.mozilla.org/comm-central/rev/f49ca303c8e4
Comment 13 User image [:MakeMyDay] 2015-04-05 05:25:24 PDT
*** Bug 511509 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.