name anchor tag doesn't work between table elements

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
P3
normal
RESOLVED WORKSFORME
18 years ago
15 years ago

People

(Reporter: ratman, Assigned: karnaze (gone))

Tracking

({compat, dataloss})

Trunk
Future
x86
Windows 98
compat, dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [awd:tbl], URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
currently using build 2000111604 win98 mtrunk, though this problem has been seen
in virtually all builds.  i hope this is a repeat of some older bug that i can't
find.

basically, <a name="foobar"></a> tags cannot be used in tables unless they are
within <td></td> tags, or the table fails to display.  this includes name anchor
tags between instances of <table> and <tr> and between <tr> and <td>, as is the
case in the url supplied.  i have seen several examples of this, but at present
only have the one url to provide; i'll add more if this isn't a duplicate (and
if i can remember them).

testable with basic do-at-home html constructions of your own as well.

this is 4xp as well.
(Reporter)

Comment 1

18 years ago
oops, my bad on the erroneous component.
Component: Installer: XPInstall Engine → HTML Element
Keywords: 4xp
trying default owner for the new component
Assignee: dveditz → clayton
QA Contact: jimmylee → lorca

Comment 3

18 years ago
Created attachment 19674 [details]
Test case

Comment 4

18 years ago
In the above test case, removing any one of
1) the <a name> in the middle of the table
2) the <br> in the middle of the table
3) the rowspan in the <td>
causes the table to be rendered in full.

Comment 5

17 years ago
According to validator.w3.org this is bad html. Marking as WONTFIX. Try fixing
the HTML and it should work. Reopen if you feel I havent done you justice ;)

Comment 6

17 years ago
Trying Again
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 7

17 years ago
Marking INVALID, since it is.  WONTFIX would mean that its a valid bug/good 
HTML...no?
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 8

17 years ago
Marking INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 10

17 years ago
qa contact updated.
QA Contact: gerardok → bsharma
Actually, I would say that the parser folks should look at this one and decide
whether they want to try to deal with it...
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Over to parser.  Parser folks, feel free to mark this wontfix/invalid.  :)
Assignee: clayton → harishd
Status: UNCONFIRMED → NEW
Component: HTML Element → Parser
Ever confirmed: true
QA Contact: bsharma → janc

Comment 13

17 years ago
Created attachment 26803 [details]
Yet another reduced case [ since the above testcase WFM )

Comment 14

17 years ago
Content model for testcase ( id=26803 ):

docshell=01655870
html@0398AB00 refcount=6<
  head@0398AA10 refcount=2<
  >
  Text@0394D2F0 refcount=3<\n >
  body@0394D160 refcount=3<
    Text@0398AE10 refcount=3<\n  >
    br@03997D90 refcount=3<>
    Text@039935E0 refcount=3<\n    >
    a@03997A30 name=top refcount=3<
      Text@03993150 refcount=3<\n     >
    >
    table@0398CE80 refcount=6<
      Text@0398CE10 refcount=2<\n   >
      tbody@0398CD60 refcount=3<
        Text@03989F30 refcount=2<\n    >
        tr@03989E40 refcount=3<
          Text@0398A8E0 refcount=2<\n     >
          td@0398A7E0 rowspan=3 valign=Top refcount=
            Text@0398CAF0 refcount=3<\n     >
          >
          Text@039885B0 refcount=2<\n    >
        >
        Text@039884B0 refcount=2<\n    >
        Comment@0398F680 refcount=2<!-- middle cell-
        tr@03996970 refcount=3<
          td@03992040 valign=Top refcount=4<
            Text@03993440 refcount=4<\n       TEXT\n
          >
          Text@03993390 refcount=2<\n    >
        >
        Text@03994590 refcount=2<\n   >
      >
      Text@039968C0 refcount=2<\n  >
    >
    Text@03997B40 refcount=3<\n >
  >
>

The content model looks correct to me ( as expected the <A> & <BR> tags are 
moved out of the table for compatibility ). This smells more like table bug. 
Giving bug to Chris.
Assignee: harishd → karnaze

Updated

17 years ago
QA Contact: janc → bsharma

Updated

17 years ago
QA Contact: bsharma → moied

Updated

17 years ago
Whiteboard: [awd:tbl]
Component: Parser → HTMLTables
(Assignee)

Comment 15

16 years ago
Temporarily moving to future until a milestone can be assigned. 
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 16

16 years ago
months later....

adding keyword "compat" based on this being bad html; however, bad html should
not cause dataloss, which occurs as well.
Keywords: compat, dataloss

Comment 17

16 years ago
wfm, or what should  happen on the second testcase I see "Text"?

Comment 18

15 years ago
as nobody opposes the wfm closing the bug
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.