[QAC generated] Unsorted bookmark file (folder) NOT show in Bookmark menu

RESOLVED WONTFIX

Status

()

--
major
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: raul.malea, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wontfix?])

(Reporter)

Description

8 years ago
Steps to Reproduce
---------------------------------------
1.Go to bookmark menu
2.Search one unsorted boomark website uncategorised
3.

What should have happened:
---------------------------------------
Unsorted bookmark file (folder) is show



What actually happened:
----------------------------------------
Unsorted Bookmark file (folder) NOT show in bookmark menu. Also this unsorted category appear in minefield button menu BUT unsorted links not show.
(Reporter)

Updated

8 years ago
Severity: normal → major
Component: General → Menus
QA Contact: general → menus
Unsorted Bookmarks is another top category and is not part of the bookmarks menu. But the second part seems to be valid. Marco, any reason why we do not show unsorted bookmarks in the firefox button?
Component: Menus → Bookmarks & History
QA Contact: menus → bookmarks
It is there in both the toolbar button and in appmenu button here, it's a menuitem at the end of the menupopup after all bookmarks. The fact it's a menuitem and not a menu is by design.
To clarify the scope of the menuitem is to open the Library on Unsorted Bookmarks.
Is there any other issue reported here?
No, as far as I can understand the initial comment correctly.
(Reporter)

Comment 5

8 years ago
Sorry for my bad english.
Back with clarifications. 
When the menu bar is displayed in the Bookmarks Menu, unsorted bookmarks category is NOT listed (not show). In button Firefox, the submenu  bookmarks, category unsorted bookmarks appear BUT not drop down arrow to the bookmarks that have not been put into a category (like recently bookmarks for example). As you can see bookmarks without access category must bookmark collection to another page, which is pretty pathetic. It should be a submenu drop down arrow as the recent bookmarks.
(Reporter)

Comment 6

8 years ago
Not have any ideea?
(Reporter)

Comment 7

8 years ago
In Firefox 3 this submenu for unsorted bookmarks appear. Is regresion? this bug blocked Firefox 4 final release.
blocking2.0: --- → ?
Whiteboard: menu
(Reporter)

Updated

8 years ago
Component: Bookmarks & History → Menus
Please stop moving bugs around. It's not a Menus bug even it looks close enough. Please add a screenshot which shows your issue. As far as I can see we never supported to show unsorted bookmarks in the menu. Is this part of an extension you have installed?
blocking2.0: ? → ---
Component: Menus → Bookmarks & History
Whiteboard: menu
Indeed afaict FX3 never had unsorted bookmarks in the menu, it was only in the Library. Nor we want to have a dropdown menu.
Current plan is just to have a link to the unsorted bookmarks part of library at the end of all bookmarks menu. And that's what happens in current FX4.
there are no plans to do anything different so far, an extension could do it.
Whiteboard: [wontfix?]
And when I say bookmarks menu in comment 9 I'm talking about the menu you get from the appmenu button or the bookmarks button in the toolbar. the old menu won't probably change from what it was in FX3.6.
(Reporter)

Comment 11

8 years ago
I understanding. In FF4 dropdown menu for unsorted bookmark in firefox orange button not implemented.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.