Closed Bug 604155 Opened 9 years ago Closed 9 years ago

Clicking an item in the awesomebar sometimes doesn't give visual feedback

Categories

(Firefox for Android Graveyard :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(fennec2.0b3+)

VERIFIED FIXED
Tracking Status
fennec 2.0b3+ ---

People

(Reporter: cjones, Assigned: vingtetun)

References

Details

STR
 (1) Open awesomebar
 (2) Click any item
 (3) Repeat

Expected results: clicking an item in the awesomebar immediately highlights it, before switching to content view.

Actual results: sometimes an item isn't highlighted before switching to content view.

This is a problem for perceived responsiveness because not highlighting makes it appear like fennec has ignored the item selection.
I think this should block 2.0 final, for UI polish.

Should add that I also saw this with fennec 1.0 and 1.1, just never filed the bug (sorry!).
tracking-fennec: --- → ?
We should already have code in place to do this.
Assignee: nobody → 21
tracking-fennec: ? → 2.0b3+
I think bug 604437 is to blame.
Depends on: 604437
This is working for me
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Marking FIXED since I think bug 604437 might have been to blame.
Resolution: WORKSFORME → FIXED
Chris, can you check this and see if its fixed for you?
I can't make this happen anymore.  (And wow, awesome bar is much awesomer with 604437!)
Mozilla/5.0 (Maemo;Linux armv71; rv:2.0b8pre) Gecko/20101018 Firefox/4.0b8pre Fennec/4.0b2pre
Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101018 Firefox/4.0b8pre Fennec/4.0b2pre

Awesome bar doesn't highlight on awesome page.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.