"All-time Top 100 (loaded initially)" Shows Only 20 Bugs

RESOLVED FIXED

Status

()

RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: david, Assigned: glob)

Tracking

Details

(Whiteboard: [bmo4.0-resolved], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.13) Gecko/20100914 SeaMonkey/2.0.8
Build Identifier: Bugzilla version 3.6.2+

I must agree that it is important to avoid submitting duplicate bug reports.  Thus, when I go to submit a new bug report, I always review the list of "All-time Top 100".  However, I recently noticed that this list contains only 20 bug reports.  

Reproducible: Always

Steps to Reproduce:
1.  Go to <https://bugzilla.mozilla.org/>.  Logon.  

2.  Select the New link to create a new bug report.  

3.  Select the Firefox product.  

4.  Scroll through the window below Step 1, counting the bug reports.  
Actual Results:  
There are only 20 bug reports listed.  

Expected Results:  
There should be 100 bug reports listed.  

I see this problem for all Mozilla-based products where I recently submitted bug reports, including Core, Bugzilla, SeaMonkey, and Thunderbird.

Comment 1

8 years ago
This has to do with some text in the guided form.
(Assignee)

Comment 2

8 years ago
caused by bug 514970, which changed default value of maxrows from 100 to 20.

one fix is to append &maxrows=100 to the duplicates.cgi urls, another is to change the text to say there's only 20, and shrink the size of the frame.
(Reporter)

Comment 3

8 years ago
I would not shrink the size of the frame.  Even with only 20 bug reports, it still requires vertical scrolling.
(Assignee)

Updated

8 years ago
Assignee: create-and-change → nobody
Component: Creating/Changing Bugs → Bugzilla: Other b.m.o Issues
OS: Windows XP → All
Product: Bugzilla → mozilla.org
QA Contact: default-qa → other-bmo-issues
Hardware: x86 → All
Version: unspecified → other
(Assignee)

Comment 4

8 years ago
text changed to say "top 20" instead of "top 100"
Whiteboard: [bmo4.0-resolved]
(Reporter)

Comment 5

8 years ago
When is this fix likely to be implemented for bugzilla.mozilla.org?
(Assignee)

Comment 6

8 years ago
it'll be fixed when we upgrade bugzilla.mozilla.org to bugzilla 4.0; current eta is mid april.
(Assignee)

Updated

8 years ago
Assignee: nobody → glob
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

8 years ago
As the originator of this bug report, I would have preferred that the "All-time Top 100 (loaded initially)" heading remained and that 100 bug reports would indeed be listed.  That might have aided conscientious users in avoiding the submission of duplicate bug reports.  

However, the header now agrees with the result.  Thus, I am forced to agree that this bug report is indeed fixed.
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.