Web console autocomplete doesn't know about variables

RESOLVED DUPLICATE of bug 587095

Status

()

Firefox
Developer Tools
RESOLVED DUPLICATE of bug 587095
7 years ago
7 years ago

People

(Reporter: heycam, Assigned: jwalker)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101012 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101012 Firefox/4.0b8pre

The web console autocomplete wants to complete to identifiers that shouldn't be unique based on the characters I have typed so far.


Reproducible: Always

Steps to Reproduce:
1. Open the Web Console on a blank page.
2. Type "var a = 1" and press Enter.
3. Type "a" and press Enter, as if you wanted to check the value of 'a'.

Actual Results:  
The autocompleter substituted "addEventListener" for "a", so I instead evaluated that.

Expected Results:  
It should not have completed "a" to "addEventListener".

Comment 1

7 years ago
Confirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

7 years ago
Assignee: nobody → jwalker
Blocks: 594225
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587095
You need to log in before you can comment on or make changes to this bug.