framesets not displaying correctly when clicking top navigation menu

VERIFIED DUPLICATE of bug 60603

Status

()

Core
Layout
P3
major
VERIFIED DUPLICATE of bug 60603
17 years ago
17 years ago

People

(Reporter: Marcel Offermans, Assigned: Stuart Parmenter)

Tracking

Trunk
mozilla0.9
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)
BuildID:    2000101015

Click on the different menu options at the top. For every option, a different
left/right frame should be displayed, but this is not the case. Other browsers
(NS 4.75, IE 4, IE 5) display the framesets correctly.

Reproducible: Always
Steps to Reproduce:
1. Open the site.
2. Click on the first link at the top.
3. Click on subsequent (second, third) links.
4. Observe that nothing changes.

Actual Results:  You keep seeing the same page.

Expected Results:  You should see different pages in the left/right frames below
the menu.

Yes, I'd like to know what's wrong, if anything, with these pages. I work for
OGD software and can change the site if necessary. Please contact me at
mailto:marrs@casema.net

Comment 1

17 years ago
So this works just fine if you wait for the image on the left to finish loading.

Comment 2

17 years ago
Over to Layout. It looks like we're spending way too much time resolving the
image or the styles associated with that frame.  Somehow this is blocking the
loading of other frames.   THis is a snip of the image's frame which takes so
long to resolve:

<html>
<head>
<link rel="stylesheet" href="http://www.ogdsoftware.com/css/style.css">
<link rel="stylesheet" href="http://www.ogdsoftware.com/css/nav.css">
</head>
<body style="background-image:url(http://www.ogdsoftware.com/images/bedrijf.jpg);
background-position: 0% 100%; background-repeat: no-repeat;
background-attachment: fixed">
<body>
<table width="100%" border="0" cellspacing="0" cellpadding="0" height="100%">
<tr valign="top">
<td> <p>&nbsp;</p>
</td>
</tr>
<tr valign="bottom"> <td><p><img
src="http://www.ogdsoftware.com/images/news.jpg" width="144" height="258"></p>
</td>
</tr>
</table>
<p>&nbsp;</p>
</body>
</html>
Assignee: asa → clayton
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: doronr → petersen
Please triage.
Assignee: clayton → harishd

Comment 4

17 years ago
This looks bad. Setting milestone to 0.8
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.8

Comment 5

17 years ago
Actually, when you click on any of the links, on the top ,while the image, on 
the left frame, is loading the right frame does not change. However, clicking 
on the link after the image,on the left frame, of the previous link is 
completely loaded, does cause the right frame to change. This is definitely not 
a parser problem. Sounds more like imglib/netlib. Giving bug to pnunn and ccing 
gagan.
Assignee: harishd → pnunn
Status: ASSIGNED → NEW

Comment 6

17 years ago
->pav for investigation
Assignee: pnunn → pavlov
(Assignee)

Comment 7

17 years ago
0.9
Target Milestone: mozilla0.8 → mozilla0.9
Possible dupes: bug 60603, bug 67188, bug 62866, bug 69001.

Comment 9

17 years ago
*** Bug 67188 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

17 years ago
fixed by the new and improved imagelib!
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Can still reproduce with 2001-04-09-04, Win NT.
And sometimes I get even the behavior reported in bug 62866: After clicking
several links while the frame is still loading Mozilla gets totally confused
and displays nothing at all (while still loading in the background).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

*** This bug has been marked as a duplicate of 60603 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 13

17 years ago
Verifications.  Tests (if necessary) were done with 2001052504 on Windows 2000.

Please forgive the spam.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.