build Firefox homepage (Fx version)

VERIFIED FIXED

Status

www.mozilla.org
General
--
blocker
VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: John Slater, Assigned: sgarrity)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [redesign], URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Somewhat related to bug 598431, we also need to create a version of the Firefox homepage for people using the latest & greatest version. This one will have content focused on informing people about personas, add-ons and mobile rather than downloads.

The PSD for the basic frame of the page is here:
http://intothefuzz.com/leetom/Mozilla.com/PSD/home_existingusers_01.psd

However, you'll notice that there's a pretty big gap in the middle of the page - we're working with TRO on an illustration that will present personas, add-ons & mobile in an interesting and engaging way. It's in the works, but not ready yet, so this bug is mainly a placeholder for now.

Will update it as soon as we have new files from TRO to add here. Thanks!
(Reporter)

Comment 1

7 years ago
Quick update on this page: are working through design concepts with TRO...will have something more solid within a week or two.

Details to come-
(Reporter)

Comment 2

7 years ago
Update: we're working out the illustration concept with TRO now. I think it'll be really good, but is going to take more time than expected. We'll need to rethink the schedule on this page (still launching with the rest on 12/8, of course).
(Assignee)

Updated

7 years ago
Depends on: 611692
(Assignee)

Comment 3

7 years ago
A very basic wireframe/prototype for this page has been added in the nova branch in r77612.
(Reporter)

Comment 4

7 years ago
Hey guys. Apologies for the delay on this. Final illustration (including various content states) is available at http://www.intothefuzz.com/mozilla/FF_ExistingUsers_Color-1.psd. 

Please let me know if you have any questions about functionality, content, etc.
(Assignee)

Updated

7 years ago
Severity: normal → blocker
page does not validate
(Assignee)

Comment 6

7 years ago
(In reply to comment #5)
> page does not validate

Thanks, that is a typo, but this page isn't ready for QA yet. Major changes still to land. Will update.
(Assignee)

Comment 7

7 years ago
Bam! Done in r79188.

Animations are using CSS3 transitions for Fx4 users and falling back to jquery powered animation.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: qawanted
Resolution: --- → FIXED
(Reporter)

Comment 8

7 years ago
Awesome, thanks Steven. 

Key question: how do the directs work? When I visit nova.stage.mozilla.com in both Chrome & Safari I still am sent to this page. We definitely need to get that fixed...let me know if I need to spin that off into a new blocker bug.
(Assignee)

Comment 9

7 years ago
(In reply to comment #8)
> Key question: how do the directs work? When I visit nova.stage.mozilla.com in
> both Chrome & Safari I still am sent to this page. We definitely need to get
> that fixed...let me know if I need to spin that off into a new blocker bug.

Syntax error in the redirect. Fixed in r79197.

With this fix, anyone visible the home page with Firefox 3.6.* or Firefox 4.* gets redirected to /fx/

Alex, can you review my redirect changes? I'd feel better with a second set of eyes on such an important change: r79192 and r79197
(In reply to comment #9)
> Alex, can you review my redirect changes? I'd feel better with a second set of
> eyes on such an important change: r79192 and r79197

Looks ok to me.  Tested it in minefield, 3.6, safari, chrome, seems to work fine.
Created attachment 496902 [details]
screenshot

In minefield, when I refresh the page, the pop-up is in a weird state, sort of in between hidden and shown.  Screenshot attached.

Could be a minefield bug, I can't reproduce the problem in 3.6
(In reply to comment #11)
> Created attachment 496902 [details]
> screenshot
> 
> In minefield, when I refresh the page, the pop-up is in a weird state, sort of
> in between hidden and shown.  Screenshot attached.
> 
> Could be a minefield bug, I can't reproduce the problem in 3.6

I couldn't reproduce the above issue in Minefield 

qa-verified-trunk  http://nova.stage.mozilla.com/en-US/firefox/fx/
Keywords: qawanted
(Reporter)

Comment 13

7 years ago
Is there a direct link to the non-users version of this page? Everything I try is redirecting me to this version.
(Reporter)

Comment 14

7 years ago
I just realized that in the mockups from TRO, the panda/carnival barker had little speech bubbles coming out of his mouth prompting you to spin the wheel and then describing the different features. Can we get those added in?

If not, probably not a blocker but we should fix soon.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #13)
> Is there a direct link to the non-users version of this page? Everything I try
> is redirecting me to this version.

Filed https://bugzilla.mozilla.org/show_bug.cgi?id=618447
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

7 years ago
Also, maybe this is up for debate, but I thought the default state was to show
the full wheel first and only have the content panels pop up when you spin?

Again, not a blocker, but that was my understanding...if that sounds right,
would be nice to get that fixed reasonably soonish.
(Reporter)

Comment 17

7 years ago
Created attachment 496938 [details]
screenshot

I'm seeing a weird regression now - this attachment shows what I'm seeing when I visit the page now. (in Fx4b7)

Reopening...
(Reporter)

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Also, there is a file 404'ing,  jquery-1.4.3.js
i missed this earlier. The link to http://nova.stage.mozilla.com/en-US/firefox/participate/ is broken
(Reporter)

Comment 20

7 years ago
I'm still getting some weirdness along the lines of what I reported in comment #17, although its a little different each time. Is anyone else seeing this?

I'm hesitant to send the site out to all@ until we have this a little more stable...
(In reply to comment #20)
> I'm still getting some weirdness along the lines of what I reported in comment
> #17, although its a little different each time. Is anyone else seeing this?

Yes, I made the same note in comment #11, and it still happens each time for me.


> I'm hesitant to send the site out to all@ until we have this a little more
> stable...

I vote you send it out, and make a note that we know this issue exists.  Time is short, and I rather not wait around for wider testing anymore.
(Assignee)

Comment 22

7 years ago
(In reply to comment #18)
> Also, there is a file 404'ing,  jquery-1.4.3.js

Fixed in r79211.

(In reply to comment #19)
> i missed this earlier. The link to
> http://nova.stage.mozilla.com/en-US/firefox/participate/ is broken

Fixed in r79211.
Committed r79335. I used PNG8 for the spinner, the stand, the creature and the wheel. This greatly improves download times.

Steven, having two jquery instances on this page is not helping peformance wise. Do you really need 1.4.3 ? Comments in jquery-css-transform.js and jquery-animate-css-rotate-scale.js claims that they fix jquery 1.3.

Of course if we're going to use 1.4.3 everywhere, my question is irrelevant.
(Assignee)

Comment 24

7 years ago
Implemented the speech bubbles, changed the initial state of the panel to hidden, made entire wheel clickable, and improved animation in r79362. Should fix the partial transition bug reported here.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Keywords: qawanted
Resolution: --- → FIXED
Keywords: qawanted
verified fixed http://www.mozilla.com/en-US/firefox/fx/
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.