Closed Bug 604268 Opened 10 years ago Closed 9 years ago

Undo-closed-tab doesn't remember a tab until around the time it's fully loaded

Categories

(Firefox for Android Graveyard :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 630398

People

(Reporter: cjones, Assigned: mfinkle)

Details

(Whiteboard: [fennec-sessionstore])

STR
 (1) Load google.com
 (2) Close its tab
 (3) Restore the closed tab
 (4) Goto (2)

Eventually tab-restore resurrects about:blank instead of google.com.

(FTR I found this while trying to repro bug 603680, I'm not mentally disturbed.)
Assignee: nobody → mark.finkle
Also while trying to repro something else, I found that killing plugin-container in the middle of loading news.google.com in a new tab and then trying to restore the tab restores about:blank.  Not sure if this would be considered a bug or not, I could see arguments both ways.  It makes more intuitive sense to me to restore the page we were attempting to load.
Summary: Undo-closed-tab can "forget" which tab closed (or, remember the wrong closed tab) → Undo-closed-tab doesn't remember a tab until around the time it's fully loaded
This is currently a limitation of the session store system. It only remembers pages that fully load. I think I have seen desktop do the same thing.
Flags: in-testsuite?
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 625257
Not a dupe. Fennec has it's own session restore and this was filed against Fennec.

Mark, I haven't looked at how Fennec is doing its session restore (though I'm interested), but it might be related to bug 625257.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Agreed, not a dupe. I have tried to use the Firefox nsSessionStor.js as a model for Fennec's SessionStore.js - but also tried to keep the Fennec system as simple as possible.

Maybe we aren't getting any session saved in our onTabAdd, also, we use "pageshow" alone, not "load" too, since we try to minimize the amount of IPC messages we send during a page load.
Whiteboard: [fennec-sessionstore]
Status: REOPENED → RESOLVED
Closed: 10 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 630398
You need to log in before you can comment on or make changes to this bug.