Closed Bug 60431 Opened 19 years ago Closed 19 years ago

Logging into www.ya.com requires a reload

Categories

(Core :: Layout, defect, P3)

x86
Linux
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: rusty.lynch, Assigned: pollmann)

References

()

Details

In recent builds I have noticed a strange behavior that I have had a hard time
reproducing in a test case. The web site above, www.ya.com, exibits this bug
when performing a login.

To login, the page calls a JavaScript function that opens a new window and then
calls a form to submit with the target for the form set to the new window.
Dynamic content returns to the second window that will redirect the opener
window and then close the secondary window.

Providing a bad password works just fine.  The main page is redirected to an
error page and the secondary window closes.  The problem occurs when the correct
username and password are given.  The secondary closes and I can see from my
printfs that the main page loaded the new content, but the page never redraws
the new content.  Since the loading the page stored a cookie, reloading the
browser opens with the personal account.

You can request a free account (or if you are spanish impaired like myself then
try the user "hhhhh" and password "hhhhh").

Another place where I think the same bug is occuring is the loggin for
www.bidwell.com.  In bidwells case, attempting to login returns a grey screen.
But since they don't set a cookie (i think) reloading doesn't do any good.
The site is on an https server and dynamicly created so it's pretty hard to see
what is going on inside.
Please triage.
Assignee: clayton → harishd
Eric, this bug smells like FORMS! Could you please take a look? Thanx.

Sorry, I couldn't come up with a reduced test case.
Assignee: harishd → pollmann
WORKSFORME
Platform: PC
OS: Windows 98
Mozilla Build: 2001012505

Marking as such.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.