bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

System wide font disappearance while running Mozilla



18 years ago
14 years ago


(Reporter: hirata masakazu, Assigned: asa)


Mac System 9.x

Firefox Tracking Flags

(Not tracked)




18 years ago
I know I have seen this one in Bugzilla before, but I could not find it by
vigorous querying.  I vaguely remember that the bug was left unconfirmed or WFM.
 Therefore, I have decided to file it here.
This has been happening in recent trunk builds.  I never experienced it when I
read the bug in Bugzilla, may be because I was using MacOS 8.6 at that time.
The bug is:
After a long period of using Mozilla, all the fonts suddenly show up blank.
This is not a crash, and you can quit Mozilla through the blank-looking pull
down menu.  You can not correct the situation by changing resolution or
Appearance or whatever control panel options available.  You have to restart the
system to get the font display back to normal.

Comment 1

18 years ago
how about memory..are you low on it when this happens?

Comment 2

18 years ago
unable to reproduce with 111708 mozilla trunk build on OS9.  I have never seen
this problem.

Comment 3

18 years ago
As to memory issue, you probably are aware that the memory usage of System
increases as you continue using Mozilla.  It approaches some limit of its own
and start to cause weird behavior.  Therefore, this bug may be caused by MacOS
such as OpenTransport.  However, I felt there is a need to file a bug since this
started to happen to me fairly recently, much more recent than when I started to
use Mozilla under OS9.04.  I have 192MB of RAM and use the memory with VM ON,
and both Mozilla and MacOS use something around 40MB each during a long use of
Mozilla.  Of course there is no way to know the amount of memory used when this
disappearance occurs, because font is invisible system-wide.
Before the bug starts to show up, I usually experience  dissapearance
 of a few chromes, such as Mozilla icon in the upper right corner and
Back/Forward switch.

Comment 4

18 years ago
I too have never seen this. But I always set the preferred memory to at least
twice the recommended size. What language Mac OS are you using?

Comment 5

18 years ago
ok, I will add something I used to see on windows with only 64 MB - icons used
to dissapear when i was low on memory and my VM was low too.  However, this was
on win98.

Comment 6

18 years ago
>What language Mac OS are you using?
Good question, since system font is dependent on primary language script used by
MacOS.  This is in Japanese system under MacOS9.04.  But this does not mean only
system becomes invisible.  All other fonts become invisible when this bug occurs.
BTW I do not think the other bug I saw in Bugzilla that describes similar
system-wide font invisibility was in Japanese MacOS.  I still can not find that
bug.  That bug had a screenshot of DeskTop, and I am quite sure that one is
similar to what I am reporting here. 

Comment 7

17 years ago
hirata masakazu, are you seeing this in 0.8 or current nightly builds.  I've
still never been able to reproduce this and I use Mac Mozilla for many hours
each day.

Comment 8

17 years ago
I have not seen this since I updated MacOS from 9.04 to 9.1.
Resolving as WFM.
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.