[d2d] When mouse hover a Link, a pixel of the right side of link text does not change to hover-color.

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

Trunk
mozilla2.0
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 -)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 483120 [details]
screenshot

Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101013 Firefox/4.0b8pre ID:20101013225426

Under condition of D2D enabled,
When mouse hover a Link, a pixel of the right side of link text does not change.

If I set gfx.direct2d.disabled to true, the problem does not happen.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open URL ( http://dic.nicovideo.jp/a/photoshop )
3. Mouse Hover "Adobe Photoshop"

Actual Results:
 a pixel of the right side of link text does not change.

Expected Results:
 no repaint issue.
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
(Reporter)

Comment 1

8 years ago
Created attachment 483121 [details]
reduced html
(Reporter)

Comment 2

8 years ago
I forgot to mention Graphics hardware.
Adapter Description: ATI Radeon HD 4300/4500 Series ---- Actually I use HD4350
Vendor ID: 1002
Device ID: 954f
Adapter RAM: 512
Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag
atidxx32
atiumdva atiumd6a atitmm64
Driver Version: 8.771.0.0
Driver Date: 8-25-2010
Direct2D Enabled: true
DirectWrite Enabled: true
GPU Accelerated Windows: 2/2 Direct3D 9
How strange, I cannot reproduce this, I have no clue at this point what could be happening.
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> How strange, I cannot reproduce this, I have no clue at this point what could
> be happening.
Umm. Try Step 3 after change several pixels window width.
No luck, I've also tried switching Aero Glass and Basic.
(Reporter)

Comment 6

8 years ago
(In reply to comment #5)
> No luck, I've also tried switching Aero Glass and Basic.
It happens on Windowws 7 Classic, Aero and Aero Basic.

So, It may depend on Graphics driver or Font-face of Japanese text part.
(In reply to comment #6)
> (In reply to comment #5)
> > No luck, I've also tried switching Aero Glass and Basic.
> It happens on Windowws 7 Classic, Aero and Aero Basic.
> 
> So, It may depend on Graphics driver or Font-face of Japanese text part.

Both would strongly surprise me.. but.. it does seem that way.
I don't think this blocks, but it sure is ugly, so I'd welcome a patch.
blocking2.0: ? → -
(Reporter)

Comment 9

8 years ago
regression windo:
Works:
http://hg.mozilla.org/mozilla-central/rev/cc06207827f4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100901 Firefox/4.0b6pre ID:20100902020913
Fails:
http://hg.mozilla.org/mozilla-central/rev/dc2939f2640d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100901 Firefox/4.0b6pre ID:20100902051352
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cc06207827f4&tochange=dc2939f2640d

And
If I set gfx.font_rendering.harfbuzz.level to 0, the problem was gone.
so, landing of Bug 569531 causes the problem
Blocks: 569531
Keywords: regression

Comment 10

8 years ago
I reproduced this, maybe cause in D2D/DW with bitmap-embedded font.

OS: Windows Vista Home Premium SP2 (ja-JP)
GFX: GeForce 8600 GTS (Driver 258.96)
UA: Mozilla/5.0 (Windows NT 6.0; rv:2.0b8pre) Gecko/20101013 Firefox/4.0b8pre
Direct2D: Enabled
DirectWrite: Enabled
gfx.font_rendering.harfbuzz.level: 1
Accelerated Window: Direct3D 9

Font for Japanese Content:
Propotional: sans-serif (Size: 16)
Serif: MS P明朝 (MS PMincho 5.00)
Sans-serif: MS Pゴシック (MS PGothic 5.00)
Monospace: MS ゴシック (MS Gothic 5.00, Size: 16)
Minimum font size: none

Default Encoding: Japanese (Shift_JIS)
(Reporter)

Comment 11

8 years ago
I cannot reproduce any more on latest m-c nightly:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11pre) Gecko/20110126 Firefox/4.0b11pre ID:20110126064706

Graphics
    Adapter Description: ATI Radeon HD 4300/4500 Series
    Vendor ID: 1002
    Device ID: 954f
    Adapter RAM: 512
    Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
    Driver Version: 8.801.0.0
    Driver Date: 
    Direct2D Enabled: true
    DirectWrite Enabled: true
    WebGL Renderer: TransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel Jan 13 2011 03:37:36)
    GPU Accelerated Windows: 1/1 Direct3D 10


Fixed range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8d52e3b68ca6&tochange=e0ea4e4d401f
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.