Search Backwards in Find dialog doesn't give correct results.

VERIFIED FIXED in mozilla0.8

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Srinivasa Rao Borusu, Assigned: kinmoz)

Tracking

Trunk
mozilla0.8
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: moz0.8, 19-Jan)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)
BuildID:    2000101014

I searched for a word in composer in forward direction and after I searched for 
the same word in backward direction using the option "Search Backwards". The 
results were not same.
With my specific case, I found 16 matches in forward direction and only 12 in 
backward search.

It skiped the following cases:
1.The word that appears more than once in a single line.
2.The words in the table.

Reproducible: Always
Steps to Reproduce:
1. Open an existing document (or new) in composer.
2. Select Edit->Find...
3. It opens the "Find in this Page" dialog.
4. Enter word to be searched.
5. Place the cursor at the top of the document and continuously click on the 
Find button till all the occurances are found.
6. Again place the cursor at the end of the document.
7. With the same search word, check the " Search backwards" option.
8. Continuously click on the Find button till all the occurances are found.
9. Compare the results.



Actual Results:  The results are not same.

Expected Results:  The results should be same. It should locate all occurances 
in backward direction also.

Comment 1

18 years ago
assigning to sfraser
Assignee: beppe → sfraser
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → mozilla0.9
i see this as well, so adding self to cc list.

also thought i had seen this when "Wrap around" was selected, but i cannot seem
to get a reproducible case... if i do, i'll add it here in case it's related to
this current issue.

Comment 3

18 years ago
Kin has fixes for find backwards.
Assignee: sfraser → kin
(Assignee)

Comment 4

18 years ago
Accepting bug. This will be fixed when I land the new Find and Replace feature.
Status: NEW → ASSIGNED

Comment 5

18 years ago
moving to mozilla0.8, this should land by 19-Jan
Whiteboard: moz0.8, 19-Jan
Target Milestone: mozilla0.9 → mozilla0.8
(Assignee)

Comment 6

18 years ago
This should have been fixed by the landing of the Find/Replace feature. (Bug #6254)
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
verified in 1/24 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.