Composer goes wacky when you make line extremely long + CRASH!!!

VERIFIED WORKSFORME

Status

()

P3
blocker
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: netdragon, Assigned: rubydoo123)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This is fun :)

I'm picking UI cause its a GDI prob.

Ok....

Make a new composer page.
View HTML source.
Replace <br> with this:
<b>MOZILLA RULES!!!</b>

Now paste this at the end of line:
MOZILLA RULES!!! 

For the fun of it, paste it like 10 times.
Then copy all the MOZILLA RULES!!! and paste them like a trillion times! NO A 
GOOGLEPLEX TIMES!!!!!!!!!! (actually 20 is probably all that is needed).

Now parts of the lines disappear! COOL! Try to edit it - it is fun! (Don't mind 
me - I'm in a weird mood - thats why I figured out this bug)


Now, do the same except add the <nobr> </nobr> tag to the line.

Now, view Normal edit mode. The line reappears and disappears when you scroll.

Now, its time to crash Mozilla. This works for me in Windows. Paste like 100 
Mozilla Rules!!! on one line. Copy all those, and keep pasting them.

LA LA LA.

After a while, Mozilla crashes. Error in GDI.EXE ;)

I recommend having a max line length of 2048 chars or something like that. 
People can always use <nobr>, and if people are editing plain text - it can word 
wrap and save it in the text file as one line. That would be a half-asked 
solution though since the problem is not due to string allocation, I think. It 
seems that you are allocating the GDI space for the window even when it isn't 
visible. I recommend only rendering a portion of the window, maybe 4 screens 
worth.

I have build 2000101014

Comment 1

18 years ago
This is *so* not a UI design issue. --> Editor.
Assignee: hangas → beppe
Component: User Interface: Design Feedback → Editor
QA Contact: mpt → sujay
WORKSFORME in 20001119 Win95.

Gerv
(Assignee)

Comment 3

18 years ago
I couldn't get it to crash, and I couldn't get it to not display correctly. The
text wrapped as expected. WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

18 years ago
Ill believe you then - someone reopen if you have a build that doesn't work.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.